Closed Bug 893508 Opened 7 years ago Closed 7 years ago

clang++ -stdlib=libc++ build fails with lots of undefined reference to `std::__1::...'

Categories

(Firefox Build System :: General, defect)

All
FreeBSD
defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed)

RESOLVED FIXED
mozilla25
Tracking Status
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

Attachments

(2 files)

Attached file error.log
It appears some std symbols are being hidden. And similar issue happens
on some platforms supported by PkgSrc.

http://pkgsrc.se/files.php?messageId=20130627155252.1A75F96@cvs.netbsd.org
Attachment #775286 - Flags: review?(mh+mozilla)
Attachment #775286 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
Please remove checkin-needed when you push.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/61c26f843961
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Comment on attachment 775286 [details] [diff] [review]
unhide ios/ostream

[Approval Request Comment]
Harmless change and one less extra patch for downstream to ship for the
next ~6 months of esr24. This affects only platforms using gcc_hidden.h.
Attachment #775286 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 806382
Comment on attachment 775286 [details] [diff] [review]
unhide ios/ostream

ease's the hipping process on different platforms and is low risk , approving for uplift.

Please help verify the patch works as expected once this lands to help us know any breakage.
Attachment #775286 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.