Need a field in manifest to specify the app has no icon on home screen

RESOLVED DUPLICATE of bug 892397

Status

RESOLVED DUPLICATE of bug 892397
5 years ago
5 years ago

People

(Reporter: jj.evelyn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Per bug 891672 describes, a 3rd-party keyboard application might have no icon displayed on homescreen. I can think of some ways to achieve it:
1. hard code the logic in homescreen, when it sees an app requests keyboard API permission, presume it's a keyboard app and ignore its icon field.
2. allow no icon specified in manifest.
3. define another field to indicate if an app's icon should be displayed on homescreen, and homescreen takes this field into account.

I think #3 is a better and general way for an app which doesn't want to shows an icon on homescreen, 3rd-party keyboard is just a case here.
(Reporter)

Updated

5 years ago
Blocks: 891672
Duplicate of bug 892397.
Evelyn, I think closing this bug and putting the other bug in dependency tree would be nice.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(ehung)
Resolution: --- → DUPLICATE
Duplicate of bug: 892397
(Reporter)

Updated

5 years ago
No longer blocks: 891672
(Reporter)

Comment 3

5 years ago
Agree this is dup of bug 892397. Have updated the dependency tree. Thanks.
Flags: needinfo?(ehung)
You need to log in before you can comment on or make changes to this bug.