The pink colour of private comment will turn to white after refreshing the page

RESOLVED FIXED in Bugzilla 4.4

Status

()

Bugzilla
User Interface
--
minor
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Simon Green, Assigned: justdave)

Tracking

Bugzilla 4.4
Bug Flags:
approval +
approval4.4 +

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
(taken from bug report at brc)

Description of problem:
The pink colour of private comment will turn to white after refreshing the page

How reproducible:
always

Steps to Reproduce:
1.visit a bug detail page.
2.enter something in the comment field and tick the private box.(didn't click button 'save changes'.)
3.refresh the page.
4.check the colour of the private comment in step2.
  
Actual results:
the pink colour turn to white. 

Expected results:
the pink colour should not be changed.
(Reporter)

Comment 1

5 years ago
Created attachment 775418 [details] [diff] [review]
v1 patch (4.4 branch)

I've also taken this bug to change the highlighting of the private comment box on the multiple changes page to the box itself, rather than the whole form. This makes it consistent with other uses of this feature.
Attachment #775418 - Flags: review?(justdave)
Comment on attachment 775418 [details] [diff] [review]
v1 patch (4.4 branch)

This patch applies to 4.4 branch only, it fails on trunk.  Looks good though.  I'll have a patch for trunk shortly.
Attachment #775418 - Attachment description: v1 patch → v1 patch (4.4 branch)
Attachment #775418 - Flags: review?(justdave) → review+
Created attachment 8365534 [details] [diff] [review]
v1 patch (trunk)
Attachment #8365534 - Flags: review?(LpSolit)

Comment 4

5 years ago
Comment on attachment 8365534 [details] [diff] [review]
v1 patch (trunk)

You honestly don't need my review to replace <foo/> (4.4) by <foo> (trunk). Just fix this tiny conflict on checkin.
Attachment #8365534 - Flags: review?(LpSolit)
Comment on attachment 8365534 [details] [diff] [review]
v1 patch (trunk)

carrying forward r+ from the other patch then. :)
Attachment #8365534 - Flags: review+
Comment on attachment 775418 [details] [diff] [review]
v1 patch (4.4 branch)

Turns out <script> isn't legal inside <table> unless it's also inside a <td> or <th> in html4 (The docs for <table> explicitly forbid it, and it generates a validation error)

Works fine in html5 though (html5 explicitly allows it).  So the trunk patch is technically fine, but we need to do something different on the 4.4 branch since 4.4 isn't using html5.
Attachment #775418 - Flags: review+ → review-
Created attachment 8365543 [details] [diff] [review]
Patch v2 (4.4 branch)

revised patch for 4.4, LpSolit pointed out the validation failure on IRC so I'll let him double-check the fix.
Attachment #775418 - Attachment is obsolete: true
Attachment #8365543 - Flags: review?(LpSolit)
(Reporter)

Updated

5 years ago
Assignee: sgreen → justdave

Comment 8

4 years ago
Comment on attachment 8365543 [details] [diff] [review]
Patch v2 (4.4 branch)

r=LpSolit
Attachment #8365543 - Flags: review?(LpSolit) → review+

Updated

4 years ago
Severity: normal → minor
Flags: approval?
Flags: approval4.4?
Target Milestone: --- → Bugzilla 4.4
Flags: approval?
Flags: approval4.4?
Flags: approval4.4+
Flags: approval+

Comment 9

4 years ago
justdave: ping? The bug is assigned to you, so please commit the patches.

Comment 10

4 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/bug/edit.html.tmpl
modified template/en/default/bug/create/create.html.tmpl
modified template/en/default/list/edit-multiple.html.tmpl
Committed revision 8935.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified template/en/default/bug/edit.html.tmpl
modified template/en/default/bug/create/create.html.tmpl
modified template/en/default/list/edit-multiple.html.tmpl
Committed revision 8665.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.