Search box should fill entire width of panel if in panel

RESOLVED FIXED in Firefox 28

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Gijs, Assigned: Gijs)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 28
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M9][Australis:P3])

Attachments

(3 attachments)

(Assignee)

Description

5 years ago
STR:

1. Enter customize mode
2. Move search box to panel
3. Exit customize mode
4. Open menupanel

(search box now has whatever width it had before being moved to the panel)

5. Restart your browser
6. Open menupanel

(search box now has the default width, or something?)

ER:

We should make sure the search box always takes up the full width of the panel, and a default width once you move it back to the navbar (unless you move it straight back in the same process to when it was next to the navbar, in which case we can probably resize it to match its previous size?)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 901203
Assignee: nobody → mdeboer
Depends on: 885086
(Assignee)

Comment 2

5 years ago
This is about the menupanel, not the overflow panel.
No longer depends on: 885086
(Assignee)

Comment 3

5 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> This is about the menupanel, not the overflow panel.

(also, to fix this properly it needs to be treated like the other wide panel widgets, which I'd like to fix by generalizing their onWidget* handlers into a single one that fixes the entire panel's ordering, which I'm working on in bug 885579)
Status: NEW → ASSIGNED

Comment 4

4 years ago
You may want to block Bug 918551 on this one.
(Assignee)

Comment 5

4 years ago
Stealing per discussion on IRC
Assignee: mdeboer → gijskruitbosch+bugs
(Assignee)

Comment 6

4 years ago
Created attachment 815365 [details] [diff] [review]
search box should fill entire width of panel, part 1: change class name, apply to search box,

This is pretty straightforward, but it isn't enough because if you've used the splitter to change the widths of the urlbar and searchbar, that width persists into the panel or palette. However, it does that now, too, and this patch makes things strictly better (and makes it possible for the Add-on SDK to use this class, too) so I want to get this out of the way while I figure out how to best deal with the width issues...
Attachment #815365 - Flags: review?(mdeboer)
Comment on attachment 815365 [details] [diff] [review]
search box should fill entire width of panel, part 1: change class name, apply to search box,

Review of attachment 815365 [details] [diff] [review]:
-----------------------------------------------------------------

This makes things nicely readable. Thanks!
Attachment #815365 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 8

4 years ago
https://hg.mozilla.org/projects/ux/rev/a5c17d687ccf
Whiteboard: [Australis:M?][Australis:P3] → [Australis:M9][Australis:P3]
(Assignee)

Comment 9

4 years ago
Comment on attachment 815365 [details] [diff] [review]
search box should fill entire width of panel, part 1: change class name, apply to search box,

>diff --git a/browser/themes/shared/customizableui/panelUIOverlay.inc.css b/browser/themes/shared/customizableui/panelUIOverlay.inc.css
<snip>
>+#search-container@inAnyPanel@,
> #edit-controls@inAnyPanel@,
> #edit-controls@inAnyPanel@ > toolbarbutton,
> #zoom-controls@inAnyPanel@,
> #zoom-controls@inAnyPanel@ > toolbarbutton {
>   -moz-box-flex: 1;
> }

I didn't land this bit because it's a no-op. New patch to fix the width coming up in a sec, which also removes the rules for the edit/zoom-controls.
(Assignee)

Comment 10

4 years ago
Created attachment 815494 [details] [diff] [review]
search box should fill entire width of panel if in panel, part 2: fix width for search panel in panels,

Simpler than I thought in the end. This works.
Attachment #815494 - Flags: review?(mdeboer)
Comment on attachment 815494 [details] [diff] [review]
search box should fill entire width of panel if in panel, part 2: fix width for search panel in panels,

Review of attachment 815494 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #815494 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 12

4 years ago
https://hg.mozilla.org/projects/ux/rev/e6cd734560ac
Whiteboard: [Australis:M9][Australis:P3] → [Australis:M9][Australis:P3][fixed-in-ux]

Comment 13

4 years ago
Created attachment 822827 [details]
australis-menu-panel-wide-item.png

This is how it currently looks like for me. So the box is now a bit too wide (or needs even margins). Shall I file a new bug, or do you intend to cover this in this bug?
(Assignee)

Comment 14

4 years ago
(In reply to Florian Bender from comment #13)
> Created attachment 822827 [details]
> australis-menu-panel-wide-item.png
> 
> This is how it currently looks like for me. So the box is now a bit too wide
> (or needs even margins). Shall I file a new bug, or do you intend to cover
> this in this bug?

Can you make a screenshot including context? I'm guessing you had the right edge of the window at the edge of the screen, which means this looks like bug 874792 to me - everything is lacking margins, which is because the "keep this panel onscreen" bits have made it narrower on the right side. This is also why the quit button looks cropped. :-(

Comment 15

4 years ago
Yeah this is due to the window reaching all the way to the edge. If I move the window to the left, the margins look good. 

Definitely needs to be fixed before Release, I guess most people are running Fx fullscreen (because mostly they have about 13" displays) … well, Bug 874792 then. Thanks!
(Assignee)

Comment 16

4 years ago
https://hg.mozilla.org/mozilla-central/rev/a5c17d687ccf
https://hg.mozilla.org/mozilla-central/rev/e6cd734560ac
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M9][Australis:P3][fixed-in-ux] → [Australis:M9][Australis:P3]
Target Milestone: --- → Firefox 28

Updated

4 years ago
Depends on: 941149

Updated

4 years ago
No longer depends on: 941149
You need to log in before you can comment on or make changes to this bug.