Geolocation page mobile menu doesn't work

VERIFIED FIXED

Status

www.mozilla.org
Bedrock
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: cremini, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1049854] )

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

Go to /firefox/geolocation, reduce the browser width to mobile-width, click on the "3 lines" mobile menu button, nothing happens.


Actual results:

Nothing.


Expected results:

The mobile menu should have opened See /firefox/ or any other sub-url.

Updated

5 years ago
Assignee: nobody → bzhao
(Assignee)

Comment 1

5 years ago
It looks like there are three pages still using jquery 1.4.4 on mozilla.org: /firefox/speed, /firefox/happy, and /firefox/geolocation

Of these three, the geolocation page is the only one that uses the responsive layout, which is where this bug gets triggered.

All three pages work fine with the jquery 1.7 version that the rest of the site uses, so they've been updated in https://github.com/mozilla/bedrock/pull/1073

Comment 2

5 years ago
Commit pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/795d17a037eee98b76b594a75150117d8f0fb9b3
Update remaining pages from jquery 1.4.4 to 1.7
Bug 893854
The /firefox/speed, /firefox/happy, and /firefox/geolocation pages having had
their legacy use of jquery 1.4.4 removed. All three pages work fine with 1.7.
Also fix a typo in nav-main-resp.js

Updated

5 years ago
Assignee: bzhao → nobody
(Assignee)

Updated

5 years ago
Assignee: nobody → steven
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [kb=1049854]
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
verified fixed https://www.mozilla.org/firefox/geolocation/
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.