Last Comment Bug 893855 - Pick up app name translations during initial submit
: Pick up app name translations during initial submit
Status: VERIFIED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Developer Pages (show other bugs)
: 1.5
: x86_64 Linux
: P3 normal (vote)
: 2013-07-18
Assigned To: Mathieu Pillard [:mat]
:
:
Mentors:
: 749813 891370 (view as bug list)
Depends on:
Blocks: 893905
  Show dependency treegraph
 
Reported: 2013-07-15 09:31 PDT by Mathieu Pillard [:mat]
Modified: 2013-07-18 08:49 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Mathieu Pillard [:mat] 2013-07-15 09:31:05 PDT
Steps to reproduce:
- Go to the developer pages, stay in english.
- Submit a packaged app with translations for the app name in 'es' and 'de'. Leave default_locale to "en".

Expected results:
- Translations for the name appear in the developers edit page, when switching language to localize for

Actual result:
- Translations aren't picked up, they don't appear when you switch locale in the developer edit page. Instead, they only appear later, when the app is reviewed and pushed to public.

Note: A similar issue exists for hosted apps, except the translations only appear the first time we update the manifest with the daily cronjob.


For new versions, updating only when the reviewer has reviewed the version makes sense. But for the initial version, it should be picked up directly, it's in pending state anyway, nobody is going to see those before they get reviewed, except the original developer.
Comment 1 Mathieu Pillard [:mat] 2013-07-15 09:33:56 PDT
*** Bug 891370 has been marked as a duplicate of this bug. ***
Comment 2 Mathieu Pillard [:mat] 2013-07-15 09:46:50 PDT
It's actually even worse for hosted app, since the cronjob will check if the manifest changed and not do anything if it hasn't. This means hosted apps *must* make a change in the manifest and wait for the cronjob after that to get their app names translations picked up by us.
Comment 3 Mathieu Pillard [:mat] 2013-07-16 06:24:51 PDT
Duplicate was P3, setting P3.
Comment 4 Mathieu Pillard [:mat] 2013-07-16 09:33:14 PDT
*** Bug 749813 has been marked as a duplicate of this bug. ***
Comment 6 Victor Carciu 2013-07-18 08:49:09 PDT
Verified as fixed for both packaged and hosted apps.

Note You need to log in before you can comment on or make changes to this bug.