Add shell function that neuters ArrayBuffer objects

RESOLVED DUPLICATE of bug 929786

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED DUPLICATE of bug 929786
5 years ago
2 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Not sure if the function should:
* just throw the buffer away
* return a new ArrayBuffer object (changing the underlying buffer's owner)
* give another global access to the buffer (changing its compartment?)

Needed for testing bug 845899 and bug 887495.
(Reporter)

Updated

5 years ago
Blocks: 845899, 887495

Comment 2

5 years ago
Whatever it does, it should go across globals to be more like neutering in the browser.  With newGlobal it's pretty easy to test cross-global stuff, so we should feed into that somehow.
(Assignee)

Updated

4 years ago
Assignee: general → nobody
neuter() function added in http://hg.mozilla.org/mozilla-central/rev/6d4ff510c117
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 929786
You need to log in before you can comment on or make changes to this bug.