JS TypeError on TopCrashers

VERIFIED FIXED in 55

Status

Socorro
Webapp
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: lonnen, Assigned: peterbe)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
There are 9 typeerrors when I load https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/25.0a1 in FF 25.0a1 (nightly). I've mapped them all back to the following line of unminified code - https://github.com/mozilla/socorro-crashstats/blob/master/crashstats/crashstats/static/crashstats/js/socorro/topcrash.js#L124

The callback in that line is being called with no arguments sometimes. We should make it more robust.
(Reporter)

Updated

5 years ago
Whiteboard: [mentor=lonnen]
I suspect this was caused by bug 876022
(Reporter)

Comment 2

5 years ago
peterbe: "I'd rather we change how we're proxying the mware in the django view code."
Whiteboard: [mentor=lonnen]
(Assignee)

Updated

5 years ago
Assignee: nobody → peterbe
Status: NEW → ASSIGNED
Duplicate of this bug: 893241
Blocks: 893338
(Assignee)

Updated

5 years ago
No longer blocks: 893338
Duplicate of this bug: 893338

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 7

5 years ago
Socorro 54 or 55?

Updated

5 years ago
Flags: needinfo?(peterbe)
(Assignee)

Comment 9

5 years ago
Because the merge was a bit chaotic as we're moving from socorro-crashstats to socorro, I'll have to refer to the guy who did it all.
Flags: needinfo?(chris.lonnen)

Comment 10

5 years ago
(In reply to Scoobidiver from comment #7)
> Socorro 54 or 55?
It seems it landed on prod, currently Socorro 53.
Flags: needinfo?(peterbe)
(Assignee)

Updated

5 years ago
Target Milestone: --- → 53

Updated

5 years ago
Flags: needinfo?(chris.lonnen)
(Reporter)

Comment 11

5 years ago
This landed everywhere.
(Reporter)

Updated

5 years ago
Target Milestone: 53 → 55
QA verified on prod - looks great, zero js errors
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.