Intermittent B2G Marionette test_multi_finger.py testMultiFinger.test_three_fingers | TimeoutException: socket.timeout | MarionetteException: Please start a session

RESOLVED DUPLICATE of bug 893841

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 893841
5 years ago
5 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=25288144&tree=Mozilla-Inbound

b2g_emulator mozilla-inbound opt test marionette-webapi on 2013-07-15 09:39:58 PDT for push 8dd428369503
slave: talos-r3-fed-015

09:44:31     INFO -  TEST-START test_multi_finger.py
09:44:37     INFO -  test_move_element (test_multi_finger.testMultiFinger) ... ok
09:44:44     INFO -  test_move_offset_element (test_multi_finger.testMultiFinger) ... ok
09:47:45     INFO -  test_three_fingers (test_multi_finger.testMultiFinger) ... ERROR
09:47:45     INFO -  ERROR
09:47:45     INFO -  ======================================================================
09:47:45     INFO -  ERROR: test_three_fingers (test_multi_finger.testMultiFinger)
09:47:45     INFO -  ----------------------------------------------------------------------
09:47:45     INFO -  Traceback (most recent call last):
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 132, in run
09:47:45     INFO -      testMethod()
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_multi_finger.py", line 56, in test_three_fingers
09:47:45     INFO -      multi_action.add(action1).add(action2).add(action3).perform()
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 191, in perform
09:47:45     INFO -      return self.marionette._send_message('multiAction', 'ok', value=self.multi_actions, max_length=self.max_length)
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 342, in _send_message
09:47:45    ERROR -      raise TimeoutException(message='socket.timeout', status=ErrorCodes.TIMEOUT, stacktrace=None)
09:47:45    ERROR -  TEST-UNEXPECTED-FAIL | test_multi_finger.py testMultiFinger.test_three_fingers | TimeoutException: socket.timeout
09:47:45     INFO -  ======================================================================
09:47:45     INFO -  ERROR: test_three_fingers (test_multi_finger.testMultiFinger)
09:47:45     INFO -  ----------------------------------------------------------------------
09:47:45     INFO -  Traceback (most recent call last):
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 162, in run
09:47:45     INFO -      self.tearDown()
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette_test.py", line 307, in tearDown
09:47:45     INFO -      self.marionette.set_context("content")
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 512, in set_context
09:47:45     INFO -      return self._send_message('setContext', 'ok', value=context)
09:47:45     INFO -    File "/home/cltbld/talos-slave/test/build/tests/marionette/marionette/marionette.py", line 328, in _send_message
09:47:45     INFO -      raise MarionetteException(message="Please start a session")
09:47:45     INFO -  TEST-UNEXPECTED-FAIL | test_multi_finger.py testMultiFinger.test_three_fingers | MarionetteException: Please start a session
09:47:45     INFO -  ----------------------------------------------------------------------
09:47:45     INFO -  Ran 3 tests in 194.017s
09:47:45  WARNING -  FAILED (errors=2)
Same root cause as bug 893841.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 893841
(Reporter)

Updated

5 years ago
Keywords: intermittent-failure
You need to log in before you can comment on or make changes to this bug.