Closed Bug 893904 Opened 6 years ago Closed 6 years ago

MIR.cpp:1584:18: warning: unused variable 'newlhs' [-Wunused-variable] (also 'newrhs')

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: dholbert, Assigned: dholbert)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

{
js/src/ion/MIR.cpp: In member function 'void js::ion::MCompare::infer(JSContext*, js::ion::BaselineInspector*, jsbytecode*)':

js/src/ion/MIR.cpp:1584:18: warning: unused variable 'newlhs' [-Wunused-variable]
      MDefinition *newlhs, *newrhs;
                   ^
js/src/ion/MIR.cpp:1584:27: warning: unused variable 'newrhs' [-Wunused-variable]
      MDefinition *newlhs, *newrhs;
                            ^
}

These variables were added a few days ago, without any usages, here:
 http://hg.mozilla.org/mozilla-central/rev/05bfd456e558#l1.65
for bug 891534.

Looks like they can be dropped.
Assignee: general → dholbert
Status: NEW → ASSIGNED
Attachment #775764 - Flags: review?(bhackett1024)
Attachment #775764 - Flags: review?(bhackett1024) → review+
Duplicate of this bug: 893433
https://hg.mozilla.org/mozilla-central/rev/f12e7c34c3e4
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.