some 1.5x assets are still missing for Homescreen app

VERIFIED FIXED

Status

Firefox OS
Gaia::Homescreen
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: rudyl, Assigned: rudyl)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:hd+, b2g-v1.1hd fixed)

Details

(Whiteboard: [GAIA_HD_ASSETS])

Attachments

(3 attachments)

+++ This bug was initially created as a clone of Bug #881149 +++

List some assets that are still missing for 1.5x,

Under style/images -
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/style/images
  app_downloading.png
  app_paused.png
  default_favicon.png
  loading_spinner.png

Under resources/images -
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/resources/images
   - Unknown.png (BTW, don't know why Unknown@2x.png is not synced here)
   - delete.png
Hi Amy,

Let's track the assets with this issue.
Thank you.
Flags: needinfo?(amylee.design)

Comment 2

5 years ago
Created attachment 777210 [details]
Homescreen Assets @1.5

Hi, 

Attached are the requested assets. I've talked to Patryk and he says there is no favicon for Firefox. Also the unknown.png is the same as downloading.png and paused.png
Flags: needinfo?(amylee.design)
Hi Amy,

1. It seems that Unknown.png is not used anymore, if that is the case, we should remove it.
   Sorry that did not figure this out.

2. default_favicon.png
   I guess we still need this, it is the default favicon we used to render the bookmark on homescreen.
   please refer to the attachment.

3. app_downloading.png@1.5x that Amy provided seems a little darker than the 1x version and the size is not 90x90.
   Please refer to http://imgur.com/a/jnQd8 to see the difference.

To summarize, we need the following assets to be updated,
Under style/images -
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/style/images
  app_downloading.png (the same for app_paused.png)
  default_favicon.png

Thank you.
Flags: needinfo?(amylee.design)
Created attachment 777695 [details]
Patch v1 - WIP

Hi Cristian,

This is just a WIP.
I think "resources/images/Unknown.png" is not used anymore.
Do you think we can remove it?

Thanks.
Attachment #777695 - Flags: feedback?(crdlc)
Attachment #777695 - Attachment mime type: text/plain → text/html
(In reply to Rudy Lu [:rudyl] from comment #3)
> Hi Amy,
> 
> 1. It seems that Unknown.png is not used anymore, if that is the case, we
> should remove it.
>    Sorry that did not figure this out.
> 
> 2. default_favicon.png
>    I guess we still need this, it is the default favicon we used to render
> the bookmark on homescreen.
>    please refer to the attachment.
> 

Please refer to http://imgur.com/a/jnQd8 to see the screenshot.
Thanks.
Yes, you're right, the resources/images/Unknown.png is not used anymmore, thanks

Comment 7

5 years ago
Created attachment 777834 [details]
Homescreen Assets @1.5

Hi, 

Attached are the graphics for app_downloading.png and app_paused.png @90x90. The colours are suppose to be darker so it's correct. I've also attached the circle and star icon to be used for the favicon since the one that was provided isn't on brand. I've included it in layers as well if you need them.
Flags: needinfo?(amylee.design)
Hi Amy,

Thanks for the update.
A few questions,

1. If the app_downloading and app_paused are the same as default.png, how could a user to differentiate the app is still in downloading between the app that is downloaded and installed but doesn't have its icon?
   If you still think we should used the same graphic for both downloading and default, then I'll just replace the original app_downloading @1x and 2x with default.png respectively.

2. So we are going to use default_favicon_star for non-branding, right?
   If so, could you please provide the same graphic @1x and @2x, which don't exist in the cod base.
   To double confirm, the original ones (with grey firefox)  are not needed, even for official branding build, right?

Thanks a lot.
Flags: needinfo?(amylee.design)

Comment 9

5 years ago
Hi Rudy, 

Let me run these questions by Patryk. He's on vacation right now and will be back Monday I believe. 

(In reply to Rudy Lu [:rudyl] from comment #8)
> Hi Amy,
> 
> Thanks for the update.
> A few questions,
> 
> 1. If the app_downloading and app_paused are the same as default.png, how
> could a user to differentiate the app is still in downloading between the
> app that is downloaded and installed but doesn't have its icon?
>    If you still think we should used the same graphic for both downloading
> and default, then I'll just replace the original app_downloading @1x and 2x
> with default.png respectively.
> 
> 2. So we are going to use default_favicon_star for non-branding, right?
>    If so, could you please provide the same graphic @1x and @2x, which don't
> exist in the cod base.
>    To double confirm, the original ones (with grey firefox)  are not needed,
> even for official branding build, right?
> 
> Thanks a lot.
Flags: needinfo?(amylee.design)
Hi all,

I found that default_favicon.png was wrongly changed to branded icon by this change,
https://github.com/mozilla-b2g/gaia/commit/5b5309d7743639cfeafb29453d02c3962ade2307#diff-15

I think we need to open another bug to track that part, Bug 895748.
I also ni Peter in that bug to see if he has the assets.
Whiteboard: [GAIA_HD_ASSETS]
Summarize the assets that we need to close this and  Bug 895748,

1. app_downloading.png & app_paused.png
   - @1.5x
   
2. branded default_favicon.png (with grey firefox)
   - @1.5x

3. unbranded default favicon.png (with a star)
   - @1x
   - @2x

--
All these assets are in 'style/images' folder -
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/style/images

Thanks.
Comment on attachment 777695 [details]
Patch v1 - WIP

Pull request updated to update the assets.
 1. Add 1.5x assets.
 2. Modify the background size for app delete icon.
 3. Replace branded default_favicon.png.
    - Note that default_favicon@2x is not available right now, so I just deleted the original branded version @2x.


Rex,

Could you please review this change?
Thank you.
Attachment #777695 - Flags: review?(rexboy)
Duplicate of this bug: 896936
Comment on attachment 777695 [details]
Patch v1 - WIP

Looks good to me.

Thanks for your patch!
Attachment #777695 - Flags: review?(rexboy) → review+
Gaia master,
6148f395e5e938f39ec89eedb1024c251b9a01d4

v1.1.0hd branch,
1dbce23b1c0d39db28235141633f7dea0bd6357f

Rex,
Thanks for the review.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.1hd: --- → fixed
Resolution: --- → FIXED
Attachment #777695 - Flags: feedback?(crdlc)

Updated

4 years ago
QA Contact: atsai

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.