If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Logo to Support Uplinq Swag Items

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Robyn Chau, Assigned: Tara (musingt))

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
>>Project/Request Title:
Logo to Support Uplinq Swag Items

>>Project Overview:
The Qualcomm Uplinq event in September will be featuring our logo on the main swag of the event, to be distributed to all 1700-2000 attendees. This includes the conference bag, a baseball hat, and a water bottle.

>>Creative Specs & Deliverables:
 - hi-res Firefox OS logo in vector format 

>>Launch Date:
2013-09-03

>>Creative Due Date:
2013-07-19

>>Mozilla Goal:
Firefox OS

>>Points of Contact:
sprasad@mozilla.com
(Reporter)

Comment 1

4 years ago
Created attachment 775945 [details]
Conference bag
(Reporter)

Comment 2

4 years ago
Created attachment 775946 [details]
Conference hat - black
(Reporter)

Comment 3

4 years ago
Created attachment 775948 [details]
Conference hat - brown
(Reporter)

Comment 4

4 years ago
Created attachment 775950 [details]
Conference water bottle
(Reporter)

Comment 5

4 years ago
Just attached images of all three swag items (two colors of hats). Would you recommend the vertical logo and wordmark for these? (http://www.mozilla.org/en-US/styleguide/identity/firefoxos/branding/) Horizontal? Please advise and I will email the appropriate file to the vendor.

Thanks!
Robyn

Updated

4 years ago
Due Date: 2013-09-03 → 2013-07-19

Comment 6

4 years ago
Hi Robyn. Will we get a chance to review the proofs of the gear before they get printed? We should definitely make that happen.

For the bag, will our logo go where the OGIO one is now? Let me know the location and I can recommend a logo to use.

For the hats, I'm thinking horizontal would be better than vertical, but honestly the logo + wordmark on a hat isn't that exciting (and will be pretty off-balance). Could we do something like just the logo on the front and then Firefox OS stitched in text on the back? Feels like this one needs some more thought.

For the water bottle, I'd recommend horizontal and have it running up the side of the bottle so it can be printed bigger.
(Reporter)

Comment 7

4 years ago
Hey John,

Yes, I've confirmed that we will receive proofs prior to printing. They have requested the vertical and horizontal logos, so I think they'll play around with a few ideas of what would look good and run it by us. I also made a reference to your suggestion of the wordmark/logo hat idea to plant that seed. Right now they have been directed to the Branding page for Firefox OS (as well as the Firefox logo for the wordmark/logo hat arrangement), so they'll have access to all the approved files.

Will send proofs for your approval when I receive them.

Thanks!
Robyn

Comment 8

4 years ago
Sounds great, thanks.

Comment 9

4 years ago
I'm going to resolve this bug, since no further work is required. 

Thanks, 
Jennifer
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.