Register Gaia's mozbrowsererror on the relevant iframe itself, to (try to) fix a leak

RESOLVED FIXED

Status

Firefox OS
Gaia::System
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Justin Lebar (not reading bugmail), Assigned: Justin Lebar (not reading bugmail))

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [MemShrink] [LeoVB+] QARegressExclude)

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
See discussion in bug 893012 comment 22 and nearby.

Filing this in a separate bug because the defect identified in bug 893012 may involve many small fixes all around gecko and gaia.
(Assignee)

Comment 1

4 years ago
Created attachment 775992 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10991

Pointer to Github pull-request
(Assignee)

Updated

4 years ago
Attachment #775992 - Flags: review?(alive)
(Assignee)

Comment 2

4 years ago
This PR also includes bug 894135, another leak-fix.  I confirmed that we do in fact need both changes.
(Assignee)

Updated

4 years ago
Assignee: nobody → justin.lebar+bug
(Assignee)

Updated

4 years ago
Whiteboard: [MemShrink]
Comment on attachment 775992 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/10991

r+, thanks
Attachment #775992 - Flags: review?(alive) → review+
merged
https://github.com/mozilla-b2g/gaia/commit/d85dbb240e000903c9cb0a7a1f8aff45b3592e28
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
There's a regression in fix of 894135. Warm boot timing measurement is failing.
Root cause: When event type is 'appopen' to be watched, the event target is frame instead of iframe.

I am going to fix this in another bug.
Blocks: 894230
(Assignee)

Updated

4 years ago
blocking-b2g: --- → leo+
Uplifted d85dbb240e000903c9cb0a7a1f8aff45b3592e28 to:
v1-train: 3724c21c68f88169a443e2a5636b65b4a4a58f59
status-b2g18: --- → fixed
I think we have to uplift https://bugzilla.mozilla.org/show_bug.cgi?id=894230 as well.

Updated

4 years ago
Whiteboard: [MemShrink] → [MemShrink] [LeoVB+]
v1.1.0hd: 3724c21c68f88169a443e2a5636b65b4a4a58f59
status-b2g-v1.1hd: --- → fixed

Updated

4 years ago
Whiteboard: [MemShrink] [LeoVB+] → [MemShrink] [LeoVB+] QARegressExclude
You need to log in before you can comment on or make changes to this bug.