Cancelling install after purchase throws an error message "install failed..." due to JS error

VERIFIED FIXED in 2013-07-25

Status

P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: krupa.mozbugs, Assigned: basta)

Tracking

2013-07-25
Points:
---

Details

(Reporter)

Description

5 years ago
steps to reproduce:
1. On marketplace-dev, start the purchase of a paid app
2. Complete (fake) purchase
3. On install trigger, cancel the install


expected behavior:
Install is cancelled.

observed behavior:
cancelling install triggers the following js error 

07-15 15:29:29.777 E/GeckoConsole(  459): Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=8cab70e-51e45e2c:1 in anonymous: [apps] App install error: DENIED
07-15 15:29:29.777 E/GeckoConsole(  459): Content JS ERROR at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=8cab70e-51e45e2c:1 in anonymous: [apps] undefined Test App (bmw)
07-15 15:29:29.777 E/GeckoConsole(  459): Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=8cab70e-51e45e2c:1 in anonymous: [buttons] App install deferred was rejected for  Test App (bmw)
07-15 15:29:29.787 E/GeckoConsole(  459): Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=8cab70e-51e45e2c:1 in anonymous: [buttons] Unsuccessful install for Test App (bmw)


ashes: 8c33e
Component: Payments/Refunds → Consumer Pages
Priority: -- → P2
Target Milestone: --- → 2013-07-18
(Assignee)

Comment 1

5 years ago
That doesn't look unexpected. The "JS ERROR" in the logs isn't a JS exception, it's a console.error() call, which is generated by us. Are you seeing a more unfortunate error somewhere?
(Assignee)

Comment 2

5 years ago
To add some detail:

- DENIED means user cancelled install
- "undefined Test App (bmw)" is the install result object (which isn't defined) concatted with the app name
- The rejections are from the deferreds cascading down
(Assignee)

Comment 3

5 years ago
We were previously showing the "install failed because of the server" notification when any app installation failed for any reason.

https://github.com/mozilla/fireplace/commit/cc3a502db759bd042a7b6518a1ccc08d4dac025b

This commit gives unique notifications for each type of failure.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Assignee: nobody → mattbasta
Target Milestone: 2013-07-18 → 2013-07-25

Comment 4

5 years ago
I have completed the fake purchase, but the button has the label "Purchasing" and the Install window is not displayed. After like 1 minute, a message is displayed at the bottom "Payment Canceled".
Logs ID: db305

Do you want me to file a new bug with this issue? Thanks
(Assignee)

Comment 5

5 years ago
Iulian: Your logs show a different issue. The server is responding with a payment incomplete message (which is an issue). We keep checking to see if the payment ever does complete, which it doesn't. That causes a timeout. Please file a new bug for that issue.

Separately, if after the minute or so you still see "Purchasing" after the "Payment Cancelled" notification, that's a bug that needs to be addressed.

Comment 6

5 years ago
I can no longer reproduce the issue I've written in comment 4.
Verified this bug as fixed, the is canceled, the purchase button changes its label from price to "Install" in MP-dev app (Unagi).
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.