help window lacks key shortcuts

VERIFIED FIXED

Status

Documentation
Help Viewer
--
major
VERIFIED FIXED
17 years ago
15 years ago

People

(Reporter: Ian Oeschger (gone), Assigned: Ian Oeschger (gone))

Tracking

({access, sec508})

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
(transferring this over from bugscape 2553).
Need to have Ctrl + W hooked up for help window. Beyond being a good-window
thing, this is an important accessibility issue.
(Assignee)

Comment 1

17 years ago
Created attachment 41274 [details] [diff] [review]
patch for adding ctrl+w shortcut to help window
(Assignee)

Comment 2

17 years ago
smfr, aaronl: would you mind taking a look at this patch and giving it your
stamp? This works as expected on my linux machine, but I'm not sure there isn't
some better method/aesthetic for getting this done in the help window--like
importing the key/cmd from elsewhere or whatever. Thanks a lot
Status: NEW → ASSIGNED

Comment 3

17 years ago
We need more than Command-W. What about Select All, Copy, Find, Find Again?

Maybe the Help window needs a full-blown menu bar. If it doesn't have one, things 
will suck on Mac.
(Assignee)

Comment 4

17 years ago
smfr: are these things I can get by importing from somewhere, or do I have to
cook them up myself in the help window. And does menubar mean menu on the other
platforms?

I was thinking that Ctrl+W would be a small good we could check into a limbo
build. If I have time and know-how, maybe I can get these other commands in too
(particularly if they are defined in some reusable form elsewhere).

Comment 5

17 years ago
Look at the view source XUL; that's probably close to what you want.

Updated

17 years ago
Blocks: 89281
(Assignee)

Comment 6

17 years ago
*** Bug 87029 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Keywords: access, fcc508
(Assignee)

Comment 7

17 years ago
Marking FIXED. The help window now has a useful set of shortcut keys: ctrl+p,
ctrl+w, ctrl+a, etc.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 9

15 years ago
.
Component: Help → User
Product: Browser → Documentation
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.