Closed Bug 894139 Opened 6 years ago Closed 5 years ago

Bookmark All Tabs should be able to bookmark pinned tabs

Categories

(Firefox :: Bookmarks & History, defect)

22 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: sergey, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Firefox is quite capable of losing pinned tabs on crashes and on being killed, which just happened to me with ~15-20 pinned tabs. I tried to bookmark them when I noticed firefox becoming slow/unresponsive, but pinned tabs are not included in bookmarks enabled. On restart, the tabs were not restored, there are no previous session. Crash recovery is enabled and worked previously for this situation.



Actual results:

I was not able to bookmark pinned tabs to back them up.


Expected results:

I should be able to bookmark pinned tabs if desired - pinned tab recovery in unreliable. There should be a checkbox, or at least an about:config...
Hmm, I cannot edit the description now, s/typo/no typo/ :(
Pinned tabs are already saved.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: Untriaged → Bookmarks & History
Resolution: --- → DUPLICATE
Duplicate of bug: 588011
How is this a dup? The other patch does exactly the reverse thing. No wonder I didn't notice this bug on older machines, it was introduced recently.

If I have time one of the upcoming weekends I can try to make a patch for about:config setting that will restore normal behavior if desired.
It's duped, because the current behavior is here by design and I don't think Mozilla will revert this.

You can code an add-on if you want. :)
(see https://support.mozilla.org/en-US/questions/931693 for details)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:26.0) Gecko/20100101 Firefox/26.0

Unable to reproduce the issue with a clean profile on Mac OS X 10.8 using latest Nightly 26.0a1 (buildID: 20130830030205). 
Can you please try with a new profile and in safe mode? 
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(sergey)
How are you trying to reproduce? I am on older version (23), but not being able to repro seems to be inconsistent with Loic's comment. Let me try to install 26 when I get home and see.

My repro on 23 is - Cmd+Shift+D, hit "Add bookmarks"; expected - new folder contains pinned tabs, actual - it doesn't. I see there's no enthusiastic support for this ticket, so if I continue not having time to provide patch please feel free to close, sorry for distraction...
Flags: needinfo?(sergey)
wontfix cause it's the expected behavior per bug 588011.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.