Clipboard is cleared on exit of UX Nightly

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: twocables, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Copy some text in UX Nightly. It can be text from anywhere.
2. Close UX
3. Try to paste the text somewhere


Actual results:

The clipboard is cleared of anything I copy in UX when I close it. However, the clipboard is NOT cleared of things I copy from somewhere else before closing UX. So, I can copy text from Notepad, close UX, and I can still paste it.


Expected results:

The clipboard should not have been cleared.

I think this began happening around 2-3 weeks ago.

Comment 1

5 years ago
Maybe Bug 888900.
(Reporter)

Comment 2

5 years ago
(In reply to Fanolian from comment #1)
> Maybe Bug 888900.

No. This is for UX Nightly, not Firefox Beta 23. So it's Trunk, not Branch. See comment #13 in that bug. She's right: UX Nightly is very different. That's why I put "UX Nightly" in the title of this bug. I didn't really think about this until she commented.
Thanks for reporting this.
I've tested it on UX Nightly 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130720 Firefox/25.0
buildID: 20130720040201

and I can reproduce the error both with ctrl-C or right click copy. Even if I've done more test because it seems to be intermittent. On 10 test it happens 9 time.

Now sure if this is a duplicate of bug 873484.
Status: UNCONFIRMED → NEW
Component: Untriaged → XUL
Ever confirmed: true
Product: Firefox → Core
Component: XUL → Widget: Win32
(Reporter)

Comment 4

5 years ago
(In reply to Tiziana Sellitto [:tiziana] from comment #3)
> Thanks for reporting this.
> I've tested it on UX Nightly 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130720 Firefox/25.0
> buildID: 20130720040201
> 
> and I can reproduce the error both with ctrl-C or right click copy. Even if
> I've done more test because it seems to be intermittent. On 10 test it
> happens 9 time.
> 
> Now sure if this is a duplicate of bug 873484.

Bug 873484 is for Firefox 21.
(Reporter)

Comment 5

5 years ago
It seems fixed in the 7-23-2013 release!

I'm happy because now I can go back to using UX Nightly as my primary browser.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.