[Buri][Call][Music][fugu] The music can paly and hear the sound in the call

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [AUDIO_COMPETING] [UX_TRIAGED])

(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 DEFECT DESCRIPTION:
 The music can paly and hear the sound in the call
 
 REPRODUCING PROCEDURES:
 1.Make a incoming call and connect it ,open speaker,then click the home key back to IDLE
 2.Enter Music ,select a song to play ,the song will play and hear the sound in the call-->KO
 NOTE:As the same step,play a video have same issue 
 
 EXPECTED BEHAVIOUR:
 The music cannot paly and hear the sound in the call
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:mid
 
 REPRODUCING RATE:5/5
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
This scenario takes about 5-6 steps:

1. Swipe the lockscreen, then tap on the green icon to answer the call.
2. Tap the speaker icon to enable the speaker.
3. Hold home to back to home screen.
4. Tap on the Music icon to launch Music app.
5. Select one song then click on it to play.

which I think if users follow all these steps, they should be "really" want to listen or share their music while they are talking to their friends on the call, so I think this might be a expected behaviour because it takes so many steps to complete this scenario, and this will not be a blocker.
Component: Gaia::Music → Gaia::System
Doesn't think this is a bug and agree #1.

Updated

5 years ago
Blocks: 897354
AFAIK 
(1) We don't block the lower priority channel to play if the user forces it to.
(2) The foreground app could always play.

I don't know what's the real need here? I recall that android also doesn't block the user to play music after it's stopped by phone voice.
Whiteboard: [AUDIO_COMPETING]

Updated

5 years ago
Depends on: 936345

Updated

5 years ago
No longer depends on: 936345

Updated

5 years ago
Duplicate of this bug: 936345

Updated

5 years ago
Summary: [Buri][Call][Music]The music can paly and hear the sound in the call → [Buri][Call][Music][fugu] The music can paly and hear the sound in the call
blocking-b2g: --- → koi?
Seems like a corner case but please check if this is a cert blocker by any means?
Flags: needinfo?(pcheng)
Fugu cannot pass Spreadtrum's system tests due to these bugs unless these bugs are either fixed or clarified won't-fix by their customer(telefonica). After discussion, we think it's better to mark these bugs as 'koi?' so they can start discussions with telefonica and everyone will be on the same page. 

Steven and I will have more discussion with Spreadtrum about nominating the blockers. Will update these bugs later.
Flags: needinfo?(pcheng)
This isn't a blocker for release - we already shipped 1.1 with this bug. Minusing.
blocking-b2g: koi? → -

Updated

5 years ago
See Also: → bug 942710

Comment 8

5 years ago
[UX_TRIAGED]

UX team is working on the audio competing guideline, and this scenario is included, also we will need the gaia audio management to implement what ux needs, so ux spec and new api are required.
Whiteboard: [AUDIO_COMPETING] → [AUDIO_COMPETING] [UX_TRIAGED]

Updated

3 years ago
Blocks: 1258652

Comment 9

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.