Closed Bug 894277 Opened 7 years ago Closed 6 years ago

[Buri][REG][Wallpaper]It should have a prompt when set the wallpaper from gallery.

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect, P1)

defect

Tracking

(blocking-b2g:koi+, b2g-v1.2 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g-v1.2 --- fixed

People

(Reporter: sync-1, Assigned: gduan)

References

Details

(Whiteboard: [leo-triage])

Attachments

(5 files)

8.69 MB, application/octet-stream
Details
8.69 MB, application/octet-stream
Details
9.50 MB, application/octet-stream
Details
981.29 KB, image/png
Details
358 bytes, text/html
djf
: review+
Details
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 Created an attachment (id=459114)
 
 DEFECT DESCRIPTION:
 It should have a prompt when set the wallpaper from gallery.
 
 REPRODUCING PROCEDURES:
 1.Settings->Enabled USB storage->back the idle
 2.Plug the Phone
 3.Long press the idle->select from camera->it prompt "camera can not be used while plugged in,Unplug the phone to view pictures".--OK
 4.Long press the idle->select from gallery->it has no any prompt. --KO
 
 EXPECTED BEHAVIOUR:
 It has a prompt when set the wallpaper from gallery.
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 Meidum
 
 REPRODUCING RATE:
 5/5
 
 For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached file 487350-Video2
Clone from brother
Clone from brother
Attached file 487350-Video2
Attached file 487350-Video1
Clone from brother
Attached image 16A+DT
It is caused by pr 875641's fixed.  Maybe we could remove this code in gallery.js.
    // If storage becomes unavailble (e.g. the user starts a USB Mass Storage
    // session during a pick activity, just abort the pick.
    if (pendingPick) {
      cancelPick();
      return;
    }

    // Switch back to the thumbnail view. If we were viewing or editing an image
    // it might not be there anymore when the MediaDB becomes available again.
    setView(thumbnailListView);

    // Lock the user out of the app, and tell them why
Flags: needinfo?(dhylands)
Flags: needinfo?(dflanagan)
Taking this bug. Should be easy to fix.

Note to the reporter: I can't view the video you've attached because MacOS does not support RAR compression.  For videos like this, it is better to upload them to a video sharing site and then link to that.
Assignee: nobody → dflanagan
Flags: needinfo?(dflanagan)
It looks like this bug also occurs when there is no sdcard in the phone: https://bugzilla.mozilla.org/show_bug.cgi?id=894835#c13
Nominating for Leo because Alex marked bug 894835 as Leo+ based on https://bugzilla.mozilla.org/show_bug.cgi?id=894835#c13

But the bug described in that comment is really this bug, and I'm going to fix it here.
blocking-b2g: --- → leo?
Flags: needinfo?(dhylands)
Leo triaging partners do not feel this is a blocker for 1.1. Over to Mozilla triage.
Whiteboard: [leo-triage]
At this point we're not taking more blockers unless they're partner-championed or critical security/regression.
blocking-b2g: leo? → -
Also this is not a certification blocker and we'd ship with this unfortunate issue, there are workarounds to changing wallpaper.
Blocks: 898141
Duplicate of this bug: 898141
Duplicate of this bug: 911272
Attached file PR to master
Propose a patch to fix it.

This patch has added a close button to execute cancelpick, in order to be consistent as camera.
Attachment #799904 - Flags: review?(dflanagan)
Comment on attachment 799904 [details]
PR to master

Thanks for taking this bug, George.  I assigned it to myself a month ago, but then I seem to have forgotten about it!

r- because your code adds the close button even when there is no pick activity. It should only appear during a pick. And you should never show the camera button and the close button at the same time.

See my comments on github.
Attachment #799904 - Flags: review?(dflanagan) → review-
Assignee: dflanagan → gduan
Comment on attachment 799904 [details]
PR to master

Thanks for your comment.
Would you mind to take a look again?
Attachment #799904 - Flags: review- → review?(dflanagan)
Comment on attachment 799904 [details]
PR to master

r- because this patch fixes the bug too narrowly. If there is a pendingPick, you also need to display a cancel button on other overlays, not just the 'pluggedin' case. Also, during a pick activity, it never makes sense to display the camera or settings buttons.  Only cancel.  See github.
Attachment #799904 - Flags: review?(dflanagan) → review-
Comment on attachment 799904 [details]
PR to master

Hi David, you're right.
This patch add cancel button in all cases when pendingpick. Please kindly check again .
Attachment #799904 - Flags: review- → review?(dflanagan)
Comment on attachment 799904 [details]
PR to master

The code looks correct to me, but I have not tested it. Also, I listed a couple of nits on github. Consider making the changes I suggest, and if it works in your testing, please land your fix!

Thanks for working on this.
Attachment #799904 - Flags: review?(dflanagan) → review+
Thanks David. Based on your comment, I made the changes as you suggested and tested.

Merged into master,
https://github.com/mozilla-b2g/gaia/commit/ff4869adc052ab2dae7ef61472fd02861f09f7fd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: - → koi+
QA Contact: mozillamarcia.knous
Duplicate of this bug: 910643
Duplicate of this bug: 885728
Uplifted ff4869adc052ab2dae7ef61472fd02861f09f7fd to:
v1.2: 933ec295e76b44850ee3188e6d94151aa70dce0e
Duplicate of this bug: 904977
Duplicate of this bug: 915043
You need to log in before you can comment on or make changes to this bug.