When the user searches for a pricetier and selects the "More" button to load more results then MP will keep loading without displaying the results

RESOLVED FIXED in 2013-08-01

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sailajan.sabaratnam, Assigned: basta)

Tracking

2013-08-01
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1. Launch MP.
2. Search for a pricetier.
3. Scroll down to the bottom of the page and select the "More" button.
4. Notice MP will display the results.
5. Navigate away from this screen and repeat step 2 and 3.



Actual results:

Notice this time MP will not display more results.


Expected results:

MP should always load more results if the user selects the "More" button.
(Reporter)

Comment 1

5 years ago
Created attachment 776498 [details]
MP will not display more results
(Reporter)

Comment 2

5 years ago
Created attachment 776509 [details]
log

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

5 years ago
I can't reproduce this bug on -dev or stage. Cache rewriting appears to work as expected and a more button isn't shown because all results are already loaded.

Please test again, and submit logs if you are able to reproduce.

https://github.com/mozilla/fireplace/tree/master/ashes#submitting-logs
Flags: needinfo?(sailajan.sabaratnam)
(Reporter)

Comment 4

5 years ago
ID: 5997a
Flags: needinfo?(sailajan.sabaratnam)
(Assignee)

Comment 5

5 years ago
After much investigating, it looks like this might be caused by having a "+" in the user token (in this case, from the email). I'll investigate more later.
Assignee: nobody → mattbasta
Component: General → Consumer Pages
Priority: -- → P2
(Assignee)

Comment 6

5 years ago
I managed to reproduce the issue and fixed it:

https://github.com/mozilla/fireplace/commit/8fcbde97d132c56b3140265bb2496e5a9910b4e3

Please reopen if the problem persists.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2013-08-01
You need to log in before you can comment on or make changes to this bug.