Ability to retrieve all products in a single REST API call

RESOLVED DUPLICATE of bug 896066

Status

()

bugzilla.mozilla.org
API
RESOLVED DUPLICATE of bug 896066
4 years ago
4 years ago

People

(Reporter: Erik Bryn, Unassigned)

Tracking

Development/Staging
x86
Mac OS X

Details

(Reporter)

Description

4 years ago
Right now, in order to get a list of all product names, I have to GET /products and then make individual GET requests for every product ID. The docs (http://www.bugzilla.org/docs/tip/en/html/api/Bugzilla/WebService/Product.html#get) say that Product.get supports an ids parameter, but that doesn't appear to work right now with the REST API. If the ids param worked, I could potentially make two GETs to get all the product names, but ideally one GET would be best.
I should have taken over this bug originally but filed a new one where I am doing the work for this issue. So duping to over there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 896066
You need to log in before you can comment on or make changes to this bug.