Hardware acceleration increases startup times

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

({perf})

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130712 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130712030203

Steps to reproduce:

Disabled HW acceleration


Actual results:

Startup was faster


Expected results:

Startup should be unaffected.

My testing is not scientific, but see here:
http://www.ghacks.net/2013/07/12/firefox-starting-slow-try-disabling-hardware-acceleration/

Possibly related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=721892

Comment 1

6 years ago
It's a pretty bad advice to disable HWA, because it used largely in content rendering and compositing, so it will degrade the perfs during browsing, which is the main part of the user experience.

Are you able to reproduce this issue with Firefox 22 and old versions?
(use a clean profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles)
Flags: needinfo?(bug.zilla)
(Reporter)

Comment 2

6 years ago
It is actually not a big issue for me - I would never disable HWA. I was just highlighting it in case it pointed to a real bug.

Some more unscientific testing with a clean profile and yes, it's slower.
Happy for the bug to be closed if you don't think it's an issue.
Flags: needinfo?(bug.zilla)

Updated

6 years ago
Keywords: perf
(Reporter)

Comment 3

5 years ago
Can anyone reproduce with more "scientific" testing?
(Reporter)

Comment 4

5 years ago
Closing this as it doesn't impact noticeably.
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.