If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FIG] Tablet layout for reading list page

RESOLVED DUPLICATE of bug 888905

Status

()

Firefox for Android
Theme and Visual Design
P1
normal
RESOLVED DUPLICATE of bug 888905
4 years ago
4 years ago

People

(Reporter: Shilpan Bhagat, Assigned: Shilpan Bhagat)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Change reading list page for tablets based on the design: http://cl.ly/image/3S3H1J1S3x0D/o
(Assignee)

Updated

4 years ago
Assignee: nobody → sbhagat
(Assignee)

Comment 1

4 years ago
Created attachment 776796 [details] [diff] [review]
[WIP] Changing layout for tablet page

First trial patch for this layout. I would eventually want to replace with HomeListView with HomeGridView. It would keep the layout the same but make it easier to adapt to a more tablet friendly view. Feedback on that? To replace the divider we can give a custom lower border to each cell.
Attachment #776796 - Flags: feedback?(sriram)

Updated

4 years ago
Blocks: 862793
Priority: -- → P1

Updated

4 years ago
Blocks: 888905
Comment on attachment 776796 [details] [diff] [review]
[WIP] Changing layout for tablet page

I find this to be a roundabout way. Why not just use a GridView in a separate XML for tablets? And since GridView and ListView extend from AbsListView, the java code can use a generic AbsListView and call methods on it. That is simpler and straightforward.
Attachment #776796 - Flags: feedback?(sriram) → feedback-
This has been implemented in bug 888905. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 888905
You need to log in before you can comment on or make changes to this bug.