Don't assume addon manager exists in memory reporters

RESOLVED DUPLICATE of bug 888693

Status

()

Toolkit
about:memory
RESOLVED DUPLICATE of bug 888693
4 years ago
4 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 776802 [details] [diff] [review]
patch

I ran into this in an e10s build. We don't have an addon manager in content processes, so we were crashing. This patch just does the null check.
Attachment #776802 - Flags: review?(n.nethercote)
Attachment #776802 - Flags: review?(n.nethercote) → review+
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 888693
You need to log in before you can comment on or make changes to this bug.