Pages Won't Finish Loading

VERIFIED DUPLICATE of bug 89643

Status

()

Core
Networking: Cache
--
blocker
VERIFIED DUPLICATE of bug 89643
17 years ago
17 years ago

People

(Reporter: sol, Assigned: Gagan)

Tracking

({smoketest})

Trunk
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+, URL)

(Reporter)

Description

17 years ago
Using the commercial branch build from today, when I visit various commercial
web sites, the pages never finish loading. It seems that most of the content on
the pages is loaded, and some, but not all, of the images load. The images that
fail to load prevent the load from being "Done" and the animated logo spins
endlessly. I have tried loading the pages in IE, and the pages load as expected.

Build ID: 2001-07-05-03 commercial branch on WinNT.

Steps to reproduce:

1. Launch the client

2. Type a URL for a commercial Web site into the URL field.

Example: http://www.yahoo.com/

Expected result: Page loads in a reasonably short amount of time.

Actual result: Most, but not all of the page is loaded. Some images fail to
load, and the throbber (i.e., animated logo) throbs incessangly.

Note: Page loads normally in IE.

Note also: I encountered this problem on a number of Web sites, including:
   http://www.adobe.com/
   http://www.apple.com/

Comment 1

17 years ago
Sol, using the same builds as you on WinNT, I don't see this problem.

Comment 2

17 years ago
yup, I see it on msn.com on the branch build today on NT. I usually type 
something like "msn.com" and hit enter. The throbber just continues...thisis not 
happening all the time however. Try entering "yahoo.com", hit ENTER..and when 
the page laods completely(if it does), enter "msn.com" and hit ENTER. This is 
how I see this bug..

Comment 3

17 years ago
dup of 82720

*** This bug has been marked as a duplicate of 82720 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
ja, ja.
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
Sol. You're referring to the throbber not stopping and some images not being 
displayed, but otherwise all of the text content is showing. Yes?

If so, this is not a duplicate (the other bug is about whole portions of the 
text content of pages (and images contained in that text) not loading, but the 
throbber has stopped).
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
Also, I think what Sol is seeing may be a newer bug or else he'd bring this up
earlier :-).  The other bug has seems have been around for some time.  Thanks
for reopening this, Sol.

Need to get this on the radar.  Shrir, was your issue with MSN new?  Ie. is this
a recent problem for you, too?

We need the correct owner for this.  chofmann - any idea on who to assign to?
(Reporter)

Comment 7

17 years ago
jrgm - When I type "www.yahoo.com" into the URL field:

*The text resolves to "http://www.yahoo.com/" (this is pretty quick)

*The Yahoo home page begins to load.

From what I can see - all of the page has loaded (all text and images) *except*
for a banner ad at the top of the page. The only unusual thing I could see about
this banner ad is that it was being served by a 3d party (non-Yahoo) server. (In
this case "http://us.a1.yimg.com/us.yimg.com/a/pr/promo/anchor/hp_website1.gif".)

Note that if you hover over the blank space where the image is *supposed* to
load, and then right-click and choose to "View Image" from the context menu, the
image is loaded - quickly! - in a new browser window.
(Reporter)

Comment 8

17 years ago
This gets a bit weirder - if I use the context menu to open the image, then go
back (using the "Back" button) to the Yahoo home page, the loading of the Yahoo
home page finishes.

If I reload the page, about 1 in 6 times, the banner ad fails to load, but I can
always correct the problem by using the context menu to "View Image" then the
"Back" button to load the Yahoo home page.
(Reporter)

Comment 9

17 years ago
Seems like - if the banner ad is in the cache - then I can load the entire Yahoo
home page. If the banner ad is not yet in the cache, I have to load the banner
ad (context menu - Load Image), then I can finish loading the Yahoo home page.

Comment 10

17 years ago
[If sol makes me mid-air-collide one more time, Pow, to the moon ... :]

Yeah, that's what I see for yahoo (and netscape.com) on win2k with this build.
An image frame is allocated in document, but the image is not shown and the 
tbrobber spins "forever". But, I can load that image by other means with no 
problem.

-> Gagan. Seems like some sort of cache/http/imglib issue. Not sure why this 
just showed up now.
Assignee: asa → gagan
Status: REOPENED → NEW
QA Contact: doronr → benc

Comment 11

17 years ago
Need to get on some sort of radar.   Sol, PDT+?
Severity: normal → critical

Comment 12

17 years ago
Lisa: I noted the msn.com thing just today...

Comment 13

17 years ago
Do the following:

1) start mozilla
2) enter 'about:cache?device=disk' in the urlbar and hit enter
3) Do 'Edit->Preferences->Advanced->Cache' and clear the memory and disk cache
4) Again, enter 'about:cache?device=disk' in the urlbar and hit enter. You 
   should now list zero entries
5) enter 'http://jrgm/perf/loadtime5/base/www.yahoo.com/index.html' in the 
   urlbar and hit enter
6) Again, enter 'about:cache?device=disk' in the urlbar and hit enter. You 
   should now list three entries. But, there is only one for the top level 
   document. Where are the cache entries for the two images?
7) go find the NewCache folder in your current profile. Aside from the 
   '__CACHE_***' entries, you should see three files. If you load them 
   into 4.x, you will see that they are the top-level document and the 
   two images. 

So, the images are downloaded, but the cache doesn't seem to know about them. 
I think this is related to the fix for bug 82418 that (partially) went in on 
the branch yesterday. I can't reproduce this bug with a build from 3am Jul 04.
I think we missed an additional patch file that was part of the fix for bug 
82418.

Comment 14

17 years ago
8) go back to 'http://jrgm/perf/loadtime5/base/www.yahoo.com/index.html'
   The images will now appear.
9) One more time, 'about:cache?device=disk' in the urlbar and hit enter. 
   Now there will be three entries showing.


This bug prevented 7 pages from loading in the page loading tests on the first
visit to each page. I imagine that I won't be able to run the ibench test with 
today's build (it doesn't have any fallback action if onload never fires). 
This is definitely a pull-it-off-the-wire bug.
Severity: critical → blocker
Keywords: smoketest

Comment 15

17 years ago
pdt+
Whiteboard: PDT+
my $0.02: i've also seen this problem --albeit recently, and only using branch
builds. a url that i've seen this at is http://home.netscape.com --at least on
new profiles where the default home page has not been changed.  [most notably
when i did my prefs perf testing today on the three lab machines, so ->all/all.] 
OS: Windows NT → All
Hardware: PC → All

Comment 17

17 years ago
just for the record: nobody is seeing this on the trunk?

Comment 18

17 years ago
-> cache.

Component: Browser-General → Networking: Cache
QA Contact: benc → tever

Comment 19

17 years ago
Tested on trunk build 2001070604 (w98) and I don't see this behavior but on 
branch build 2001070503(w98) I see this behavior on www.news.com (thanks Sujay) 
everytime I go straight to the site or reload. When using the back button the 
throbber stops. 

Comment 20

17 years ago
This is a dup of 89643

*** This bug has been marked as a duplicate of 89643 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 21

17 years ago
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.