Java applets do not load or run

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
18 years ago
8 years ago

People

(Reporter: john.womack, Assigned: edburns)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

In both Mozilla (all versions so far) and Netscape 6 (all version) java applets
do not load or run.  I am on a PC, WindowsNT 4.0 sp6, 124MB ram. Have loaded and
tried to use JRE 1.3.1, 1.4 and 1.3_1.  Each has failed to solve the problem. 
currently have Sun's JRE 1.3_1 on the machine.  Both NS6 and Mozilla plugin
directories have the files needed to run JAVA as installed by the JRE 1.3_1
installer.

This happens all the time.  A good place to see this is http://www.7am.com.

below is an example error.

java.lang.ClassNotFoundException: java.net.SocketException: JVM_SetSockOpt()
TCP_NODELAY (code=10055)

	at java.net.PlainSocketImpl.socketSetOption(Native Method)

	at java.net.PlainSocketImpl.setOption(Unknown Source)

	at java.net.Socket.setTcpNoDelay(Unknown Source)

	at sun.net.www.http.HttpClient.openServer(Unknown Source)

	at sun.net.www.http.HttpClient.openServer(Unknown Source)

	at sun.net.www.http.HttpClient.<init>(Unknown Source)

	at sun.net.www.http.HttpClient.<init>(Unknown Source)

	at sun.plugin.protocol.jdk12.http.HttpClient.<init>(Unknown Source)

	at sun.plugin.protocol.jdk12.http.HttpClient.New(Unknown Source)

	at sun.plugin.protocol.jdk12.http.HttpURLConnection.privBlock(Unknown Source)

	at
sun.plugin.protocol.jdk12.http.HttpURLConnection$PrivilegedBlockAction.run(Unknown
Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.plugin.protocol.jdk12.http.HttpURLConnection.connectStep2(Unknown Source)

	at sun.plugin.protocol.jdk12.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.protocol.jdk12.http.HttpURLConnection.getInputStream(Unknown Source)

	at java.net.HttpURLConnection.getResponseCode(Unknown Source)

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)



Reproducible: Always
Steps to Reproduce:
1. load page with java applet
2. watch as java applet fails to load 

3.

Actual Results:  What happens?  nothing happens,  the applet is notinited.  

Expected Results:  Personal opinion is use the same JRE as NS4.7, I guess.

Comment 1

18 years ago
moving to oji
Assignee: idk → edburns
Component: Java-Implemented Plugins → OJI
(Assignee)

Comment 2

18 years ago
WORKSFORME with 29 June trunk build and JDK1.3.1.  I even voted in the poll.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

18 years ago
Voted in what poll.  Do you mean to say I should download and stall the 29 June 
build?  Will this solve the problem of java applets not running?  Surprising 
thing is I have the exact same build installed at home on a Win98 system and 
the JRE works perfectly.  Here at work I have a WinNT Sp6 system and  Java 
under a Sun JRE never works.
(Assignee)

Comment 4

18 years ago
The applet that doesn't work was a poll applet.  Since it worked for me, I 
voted in the poll.

If you could try a mozilla trunk build, you could use a nightly, that is less 
than a week old, and post the results, that would help immensely.

Thank you for your help!

Ed

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.