Closed Bug 894797 Opened 9 years ago Closed 9 years ago

FPE crash in OdinMonkey-generated code with % %

Categories

(Core :: JavaScript Engine, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 894786

People

(Reporter: jruderman, Unassigned)

Details

(Keywords: crash, regression, testcase)

(function() {
  "use asm";
  function f()
  {
    return ((((0xeeeeeeee | 0) % ((1 ? 0xbbbbbbbb : 0) ^ (0 | 0))) | 0) % (-1))|0;
  }
  return f;
})()();

The first bad revision is:
changeset:   http://hg.mozilla.org/mozilla-central/rev/f1088655c731
user:        Jan de Mooij
date:        Tue Jul 09 10:23:58 2013 +0200
summary:     Bug 864400 - Optimize ModI for non-constant power-of-2 divisors. r=h4writer
nbp thinks bug 894786 part 2 will fix this.

nbp, want to add this testcase when you land that patch?
Assignee: general → nicolas.b.pierron
(In reply to Jesse Ruderman from comment #1)
> nbp thinks bug 894786 part 2 will fix this.
> 
> nbp, want to add this testcase when you land that patch?

Sorry, I did not see your comment in time.
And checking locally it seems to be fixed.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 894786
Assignee: nicolas.b.pierron → nobody
You need to log in before you can comment on or make changes to this bug.