[Buri][Wallpaper]It will exit automatically when first set the wallpaper from Wallpaper or Gallery.

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sync-1, Assigned: alive, NeedInfo)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:-)

Details

Attachments

(5 attachments)

28.54 KB, application/octet-stream
Details
278.68 KB, application/octet-stream
Details
278.34 KB, application/octet-stream
Details
23.71 KB, application/octet-stream
Details
87 bytes, text/html
timdream
: review+
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 
 Created an attachment (id=463633)
 Problem video
 
 DEFECT DESCRIPTION:
 It will exit when first set the wallpaper from Wallpaper or Gallery
 
 REPRODUCING PROCEDURES:
 1.Down finished the new version,power on the phone.
 2.Long press the idle to set the wallpaper->select from Wallpaper or Gallery->
 it will exit. --KO
 
 Comment:
 1.Down完版本后开机,在idle界面长按设置墙纸,第一次进入Wallpaper
 或Gallery时会直接退出。 --KO
 
 EXPECTED BEHAVIOUR:
 It can enter the Wallpaer or Gallery when first set the wallpaper.
  
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 Medium
 
 REPRODUCING RATE:
 5/5
 
 For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 777010 [details]
490355-logcat
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 777012 [details]
Problem video

Updated

5 years ago
Flags: needinfo?(dhylands)

Updated

5 years ago
Flags: needinfo?(dhylands) → needinfo?(dflanagan)
David Flanagan will be back on Monday, so I'll defer this to him to answer, as I'm not familiar with the wallpaper stuff.
Flags: needinfo?(dhylands)

Updated

5 years ago
blocking-b2g: --- → leo?
I think I've seen this bug recently - maybe on yesterday's build?
I'm not sure I understand the bug report. And MacOS doesn't know how to deal with rar compressed files. Please clarify the bug description or re-create the attachments without using rar.
Flags: needinfo?(dflanagan) → needinfo?(sync-1)

Comment 8

5 years ago
Created attachment 779010 [details]
VID_0004.zip
Flags: needinfo?(sync-1)

Comment 9

5 years ago
Created attachment 779012 [details]
logcat.zip

Comment 10

5 years ago
(In reply to David Flanagan [:djf] (PTO 7/3-7/19) from comment #7)
> I'm not sure I understand the bug report. And MacOS doesn't know how to deal
> with rar compressed files. Please clarify the bug description or re-create
> the attachments without using rar.

I have re-create the attachments,please help check.
David, 

I think he says: 

He is long pressing at the home screen to have the option menu and choose wallpaper or gallery. These two apps will close automatically at the first time after a fresh install.

BTW, I installed the same version image and did the same procedure. I can't reproduce it.

Those two parts are the same, one is in english and another is in chinese. 

 REPRODUCING PROCEDURES:
 1.Down finished the new version,power on the phone.
 2.Long press the idle to set the wallpaper->select from Wallpaper or Gallery->
 it will exit. --KO
 
 Comment:
 1.Down完版本后开机,在idle界面长按设置墙纸,第一次进入Wallpaper
 或Gallery时会直接退出。 --KO

To buri.blff, 

You should not type Chinese here. Lots of people in Bugzilla unable to read Chinese.
(建議下次別打中文了...這邊不是每個人都看得懂中文....)
I had test with version 20130718230225 and still unable to reproduce.

I put qawanted to request helps from QA.
Keywords: qawanted

Updated

5 years ago
QA Contact: ahubenya

Comment 13

5 years ago
I was able to reproduce this issue when selecting the Gallery link, but it did not reproduce with the Wallpaper link. This only reproduces when no SD card is present. 


Environmental Variables
Build ID: 20130722070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: 41d10fb10be6916e6554eb440d9a97130ef23ce0
Platform Version: 18.1
Keywords: qawanted
leo+ given the reproduction in comment 13. This is a poor initial experience, and thus a high priority.
Assignee: nobody → dflanagan
blocking-b2g: leo? → leo+
The bug described in comment 13 sounds different to me than the initial bug described here.

Initial bug: 

  - only happens after a fresh install
  - affects Gallery and Wallpaper
  - no mention of removed sdcard
  - I cannot reproduce

Comment 13:

  - doesn't need a fresh install
  - only affects the Gallery app
  - only occurs if the sdcard is removed
  - I can reproduce.
I'm unable to reproduce using the July 2nd build, when flashing it from my desktop.

The reporter wrote "down finished the new version" and the attached logcat has lots of "fota" messages, so I wonder if reproducing this bug requires an over-the-air update?

The logcat includes GonkMemoryPressure messages. Maybe activities are being killed?
I can't reproduce this bug right after an OTA update, either.  All my testing has been on a Unagi device however.
The bug described in comment 13 is, I think, another symptom of bug 894277, and I will fix it in that bug.

I won't be able to fix this one unless someone can tell me how to reproduce it, however.

Resetting qa wanted, and setting needinfo for sync-1 and buri.biff: can you still reproduce this bug? And if so, please specify what hardware you're using and exactly what you do to reproduce.

If this is a memory issue following an OTA update, it is not something that I will be qualified to fix.  I note that the attached logcat includes no JavaScript errors, so I fear that this is a gecko bug, not gaia.
Flags: needinfo?(sync-1)
Flags: needinfo?(buri.blff)
Forgot to set qawanted...  Angela, could you try testing on a buri device after an OTA update?  Or do you have any way to get in touch with the orignal reporter and ask for more details?
Keywords: qawanted

Comment 20

5 years ago
(In reply to David Flanagan [:djf] from comment #18)
> The bug described in comment 13 is, I think, another symptom of bug 894277,
> and I will fix it in that bug.
> 
> I won't be able to fix this one unless someone can tell me how to reproduce
> it, however.
> 

We find another way to reproduce easily,the step is like this:
1.change language via settings,then back to home. 
2.Long press the idle to set the wallpaper->select from Wallpaper or Gallery->
 it will appear. --KO
Flags: needinfo?(buri.blff)

Comment 21

5 years ago
And we find this logs in dmesg:
<3>[  207.934493] mpd_ppp: error scaling when size is 1!
<4>[  238.684611] select 405 (Usage), adj 6, size 6924, to kill
<4>[  238.684641] select 1040 (Settings), adj 6, size 7671, to kill
<4>[  238.684654] send sigkill to 1040 (Settings), adj 6, size 7671

We also find that if settings and wallpaper both exist, when we kill settings, the wallpaper will exist. We don't know the relation beteew them, please help check. Thanks.

Updated

5 years ago
Flags: needinfo?(sync-1) → needinfo?(dflanagan)
I still can't reproduce using an unagi device and the steps in comment 20.

buri.blff: You still haven't specified what hardware you're seeing this bug on.

Displaying images is very memory intensive and the wallpaper app opens lots of images. Have you customized the build to add more wallpaper images (or to add larger ones)? When I open the wallpaper app, I see 10 wallpaper choices. If you have more on your device, that could be causing increased memory usage.

If that is the issue, then we might be able to use visibility_monitor.js to solve it.  

But if that is not the issue, then I think we have a gecko issue here, and I am not the right one to work on it.
Flags: needinfo?(dflanagan) → needinfo?(buri.blff)

Comment 23

5 years ago
I was not able to reproduce this issue after OTA. I tried the steps from comment 20 and comment 21 as well and had no luck. I tested on the Buri device. 

Leaving qawanted for someone else to try. 

I will log a separate bug for comment 13.

Comment 24

5 years ago
(In reply to David Flanagan [:djf] from comment #22)
> I still can't reproduce using an unagi device and the steps in comment 20.
> 
> buri.blff: You still haven't specified what hardware you're seeing this bug
> on.
> 

We use Buri device. Maybe you could see this issue like this:
1.1.change language via settings,then back to home. 
2.Long press the idle to set the wallpaper->select from Wallpaper.
3.Input b2g-ps,you may see like this:
root@android:/ $ 
root@android:/ # b2g-ps                                                        
APPLICATION      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      137   1     208736 65096 ffffffff 400fe430 S /system/b2g/b2g
Homescreen       app_444   444   137   99008  30552 ffffffff 400c4430 S /system/b2g/plugin-container
Usage            app_470   470   137   73848  25536 ffffffff 4003d430 S /system/b2g/plugin-container
Settings         app_1131  1131  137   78432  27212 ffffffff 400d5430 S /system/b2g/plugin-container
Wallpaper        app_1322  1322  137   98376  38124 ffffffff 40104430 S /system/b2g/plugin-container
root@android:/ # 

4.kill settings, you will find the wallpaper also exist.

As far as I know, settings and Wallpaper are two apps, they doesn't have dependencies relationship. But now if settings was killed,the wallpaper also been killed.
Flags: needinfo?(buri.blff)

Updated

5 years ago
Flags: needinfo?(alive)

Updated

5 years ago
QA Contact: ahubenya

Updated

5 years ago
QA Contact: sparsons
Unassining myself from this one. I don't have a Buri device and can't reproduce.  I haven't tried reproducing comment 24, but even if I could I'd have no idea how to fix that.

Alive, do you have any thoughts about this, or know who would be good to work on it?

Angela: no need to file another bug, what you describe in comment 13 will be fixed as part of 894277.

Alex: you assigned this to me based on comment 13. Just pinging you here because I'm unassigning myself.
Assignee: dflanagan → nobody
Flags: needinfo?(akeybl)
Flags: needinfo?(ahubenya)

Comment 26

5 years ago
I already logged bug 898141 to keep track of the issue regarding comment 13 yesterday.
Flags: needinfo?(ahubenya)
Sounds like we don't have clear STR here to prove this is happening on our side. Renom as such.
blocking-b2g: leo+ → leo?
Agreed Jason. Until we can reproduce in our builds we can't block on this bug.
blocking-b2g: leo? → -
Flags: needinfo?(akeybl)
Can't reproduce on a 7/30 b2g18 unagi build either.
Keywords: qawanted
Whiteboard: [closeme 8/6/2013]
Don't what to do because non-reproducible. Clear ni.
Flags: needinfo?(alive)

Comment 31

5 years ago
Hi Alex and Alive, 

For Comment 24,  do you have any thoughts about this? In our side, this issue also exist, please help check. Thanks.

Updated

5 years ago
Flags: needinfo?(alive)
Flags: needinfo?(akeybl)

Comment 32

5 years ago
Hi All,

we find when we set wallpaper from homescreen via gallery(or wallpaper/camera), if another app(like settings) was killed, the gallery will be exit. 

So we find an easy step to reproduce it: luanch more apps(more than 6), then set wallpaper from homescreen via gallery, the gallery will exit automatically.

And I test in gallery.js, if another app was killed, it will receive 'mozvisibilitychange', and the "document.mozHidden && pendingPick" is true, So the 
Gallery will exit. 
window.addEventListener('mozvisibilitychange', function() {
  if (document.mozHidden && pendingPick){
    cancelPick();
   }
});

I think this is reason the issue happens. Please help check. Thanks.

Updated

5 years ago
Flags: needinfo?(jsmith)
I'll put qawanted to try testing this with comment 32's STR
Flags: needinfo?(jsmith)
Keywords: qawanted

Updated

5 years ago
QA Contact: sparsons

Updated

5 years ago
QA Contact: dsubramanian
Upon further discussion, I don't understand why comment 32 is a bug. Can you clarify?
Keywords: qawanted
Whiteboard: [closeme 8/6/2013]

Comment 35

5 years ago
(In reply to Jason Smith [:jsmith] from comment #34)
> Upon further discussion, I don't understand why comment 32 is a bug. Can you
> clarify?

The bug is that it will exit automatically when set the wallpaper from Wallpaper or Gallery. 

Reproduce step: luanch more apps(more than 6), then Long press the idle to set the wallpaper->select from Wallpaper or Gallery-->it will exit-->KO.
(In reply to Ray REN from comment #32)
> Hi All,
> 
> we find when we set wallpaper from homescreen via gallery(or
> wallpaper/camera), if another app(like settings) was killed, the gallery
> will be exit. 

How do you kill another app while you're picking wallpaper?

> 
> So we find an easy step to reproduce it: luanch more apps(more than 6), then
> set wallpaper from homescreen via gallery, the gallery will exit
> automatically.
> 
> And I test in gallery.js, if another app was killed, it will receive
> 'mozvisibilitychange', and the "document.mozHidden && pendingPick" is true,

This is not true.
Page visibility state is by app; background app is killed (by crash or OOM killer) doesn't affect foreground app's visibility.
Flags: needinfo?(alive)

Comment 37

5 years ago
(In reply to Alive Kuo [:alive] from comment #36)
> (In reply to Ray REN from comment #32)

> How do you kill another app while you're picking wallpaper?
> 
I killed another app(not broswer) via b2g-ps, like comment 24.


> This is not true.
> Page visibility state is by app; background app is killed (by crash or OOM
> killer) doesn't affect foreground app's visibility.

I also know it should't happen. But I add logs in gallery, it receive
'mozvisibilitychange' when other app was killed.
(In reply to Ray REN from comment #37)
> (In reply to Alive Kuo [:alive] from comment #36)
> > (In reply to Ray REN from comment #32)
> 
> > How do you kill another app while you're picking wallpaper?
> > 
> I killed another app(not broswer) via b2g-ps, like comment 24.
> 
> 
> > This is not true.
> > Page visibility state is by app; background app is killed (by crash or OOM
> > killer) doesn't affect foreground app's visibility.
> 
> I also know it should't happen. But I add logs in gallery, it receive
> 'mozvisibilitychange' when other app was killed.

Let me clarify, he STR is:
1. Open app a
2. Goto homescreen
3. Long press
4. Choose gallery
5. Use adb to kill app a

Actual:
Gallery activity is killed?
(In reply to Ray REN from comment #37)
> (In reply to Alive Kuo [:alive] from comment #36)
> > (In reply to Ray REN from comment #32)

I guess it's because:
0. Gallery inline activity consumes too much memory.
1. Background app is killed by OOM killer.
2. Window manager gets mozbrowsererror(fatal) event, and it checks:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/window_manager.js#L1646
3. Window manager kills the background app and re-display homescreen and remove all inline activities.
Assignee: nobody → alive
Component: Gaia::Gallery → Gaia::System
Created attachment 792060 [details]
https://github.com/mozilla-b2g/gaia/pull/11602

https://github.com/mozilla-b2g/gaia/pull/11602

Patch v1: Check currently app == homescreen == crashed app before relaunching it.
Attachment #792060 - Flags: review?(timdream)
Nominate leo. I think this is a general bug if:
1. There's an app in background.
2. There're many images in the gallery
Then the gallery activity would be incorrectly killed by Window Manager.
blocking-b2g: - → leo?

Updated

5 years ago
QA Contact: dsubramanian
master
https://github.com/mozilla-b2g/gaia/commit/cb570cfa20e0d54db1d498fde0d37ced31324698
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Need UI take on this
Flags: needinfo?
There's not enough information to make a decision on by triage group.

Alive, since you were able to fix this, can you summarize it? Please list the STR, the user impact, and whether a specific device is required. Thanks!
Flags: needinfo?
(In reply to Dietrich Ayala (:dietrich) from comment #45)
> There's not enough information to make a decision on by triage group.
> 
> Alive, since you were able to fix this, can you summarize it? Please list
> the STR, the user impact, and whether a specific device is required. Thanks!

STR:
0. Have arbitrary app at background
1. Choose wallpaper from homescreen using Gallery activity

Expected:
Gallery is correctly shown

Actual:
Gallery activity is removed if there's any app in background to be killed. This is easy to happen if you have lots of images.

User impact:
User is not able to change the wallpaper from gallery.

No specific device. It's a general issue from long time ago, and I suspect v1.0.1 has the same problem.
Why is it a blocker if we shipped 1.0.1 with the same issue?
Thanks Alive ! Given where we are in the cycle and this is the same experience as 1.0.1, even if its a simple fix its hard to push it in 1.1 .So lets get this rsolved in the future release.
blocking-b2g: leo? → -
You need to log in before you can comment on or make changes to this bug.