[STK]The value of the GET INPUT textbox remains previous value.

RESOLVED FIXED in Firefox OS v1.1hd

Status

Firefox OS
Gaia::System
P1
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: gerard)

Tracking

unspecified
1.1 QE4 (15jul)
Other
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [TD-64763][u=commsapps-user c=messaging p=1])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Pre condidition:
Insert  SIM Card profile 7

Description:
Turn on Mobile,
Wait register in network;
Go to  settings > Vivo Chip> Games>  Vivo Ego >  Register > Nick Name > Man >  Age;
Check Behavior.

Expected:
After entry with a value in field and go to next, the next  field should be empty.

Actual:

The values ??that are entered in the field "nickname" appear in the field of "age".
Example: If typing in the nickname  "Test 123" and press ok, the next step which is the old field will be filled with "test 123" too.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
(Reporter)

Updated

5 years ago
Whiteboard: [TD-64763]
(Reporter)

Updated

5 years ago
Flags: needinfo?(frsela)
(Reporter)

Comment 1

5 years ago
We insert the code blow (this.icc_input_box.value="";)
Please check this code.

    if (!this.icc_input) {
      this.icc_input = document.getElementById('icc-input');
      this.icc_input_msg = document.getElementById('icc-input-msg');
      this.icc_input_box = document.getElementById('icc-input-box');
      this.icc_input_btn = document.getElementById('icc-input-btn');
      this.icc_input_btn_yes = document.getElementById('icc-input-btn_yes');
      this.icc_input_btn_no = document.getElementById('icc-input-btn_no');
      this.icc_input_btn_back = document.getElementById('icc-input-btn_back');
      this.icc_input_btn_help = document.getElementById('icc-input-btn_help');
    }

    this.icc_input_box.value="";
(Assignee)

Comment 2

5 years ago
I think I might be reproducing this issue here.
(Assignee)

Comment 3

5 years ago
(In reply to Leo from comment #1)
> We insert the code blow (this.icc_input_box.value="";)
> Please check this code.
> 
>     if (!this.icc_input) {
>       this.icc_input = document.getElementById('icc-input');
>       this.icc_input_msg = document.getElementById('icc-input-msg');
>       this.icc_input_box = document.getElementById('icc-input-box');
>       this.icc_input_btn = document.getElementById('icc-input-btn');
>       this.icc_input_btn_yes = document.getElementById('icc-input-btn_yes');
>       this.icc_input_btn_no = document.getElementById('icc-input-btn_no');
>       this.icc_input_btn_back =
> document.getElementById('icc-input-btn_back');
>       this.icc_input_btn_help =
> document.getElementById('icc-input-btn_help');
>     }
> 
>     this.icc_input_box.value="";

It seems to be working as expected, and I can't see any side effect when testing here, I'll open a pull request.
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: nobody → lissyx+mozillians
(Assignee)

Comment 4

5 years ago
Created attachment 779066 [details]
Link to Github https://github.com/mozilla-b2g/gaia/pull/11089

Please find a link to Github pull request https://github.com/mozilla-b2g/gaia/pull/11089 that addresses the issue.
Attachment #779066 - Flags: review?(frsela)
(Assignee)

Updated

5 years ago
Whiteboard: [TD-64763] → [TD-64763][u=commsapps-user c=messaging p=1]
Attachment #779066 - Flags: review?(frsela) → review+
Flags: needinfo?(frsela)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 60aefda83553a7d9d96691ec28cc237bdaed571e to:
v1-train: 271fb7204c3d8c2a52d69e1c0e6aa4d7414b9fa8
status-b2g18: --- → fixed
v1.1.0hd: 271fb7204c3d8c2a52d69e1c0e6aa4d7414b9fa8
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.