vertical panning stutters and fails

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: paul, Unassigned)

Tracking

22 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Navigate to any website with enough content to require vertical panning to see all of it. After the page has finished loading, attempt to pan down steadily (not slide and release).


Actual results:

Panning stutters and fails to move the page.


Expected results:

Panning should be smooth.
(Reporter)

Comment 1

5 years ago
This behavior disappears (panning becomes smooth again) when a page is zoomed by any amount.

This issue appears to be new to version 22.
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Which Android device and OS version? Do you have an example site? Do you see this on Nightly? (http://nightly.mozilla.org) for Android?
(Reporter)

Comment 3

5 years ago
Galaxy Note 2, Android version 4.1.2.

I'm not putting nightly on this unless you really need me to, frog knows what else will break. I regret updating to 22 as it is.

Try http://slashdot.org/, though almost any site will do.
Nightly will co-exist with 22 without any overlap. You can use it and remove it without affecting your Firefox 22 install.
(Reporter)

Comment 5

5 years ago
This is the only link I found to get a nightly build for a version other than the latest, http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ and yet these folders seem to only contain builds for Windows Mac and Linux, not Android. If you could tell me where I could get the 22 nightly build for Android I'll test that.

I have confirmed that the bug is not present in the nightly build for 25.
(In reply to Paul Gordon from comment #5)
> This is the only link I found to get a nightly build for a version other
> than the latest, http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ and
> yet these folders seem to only contain builds for Windows Mac and Linux, not
> Android. If you could tell me where I could get the 22 nightly build for
> Android I'll test that.
>

I linked it in comment #2 - http://nightly.mozilla.org - you want the 30MB APK under Android.
 
> I have confirmed that the bug is not present in the nightly build for 25.

?
(Reporter)

Comment 7

5 years ago
Oh, there is only one nightly build... right.

The bug is gone for the nightly build. Does that mean I should have checked the nightly build before reporting this bug? Is it a duplicate?
(In reply to Paul Gordon from comment #5)
> This is the only link I found to get a nightly build for a version other
> than the latest, http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/ and
> yet these folders seem to only contain builds for Windows Mac and Linux, not
> Android.

For future reference the Android nightly builds can be found at http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/. But yes, there is "only one" nightly (i.e. currently for FF 25). That means either a bug was filed about this issue and it was fixed already (so this bug is a duplicate) or it was something that just got fixed randomly without a bug. Either way we should figure out what fixed it and uplift that fix to FF 24 and FF 23 if it's not there already.
(Reporter)

Comment 9

5 years ago
Sorry, this was behavior caused by the Quick Gestures add-on. I did test with it disabled, but apparently it needed to be uninstalled or FF restarted for the behavior to go away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.