Closed Bug 894933 Opened 6 years ago Closed 6 years ago

crash in gfx3DMatrix::CanDraw2D(gfxMatrix*) const

Categories

(Core :: Graphics: Layers, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla30
Tracking Status
fennec + ---

People

(Reporter: kbrosnan, Assigned: BenWa)

Details

(Keywords: crash, regression, reproducible, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-8c633977-4434-4e1d-b32b-be1992130717 .
 ============================================================= 

This is a somewhat easy crash to hit on a Samsung GT-S5360 ARMv6 phone. Every time I hit this I was interacting with the awesome screen, often typing. 

More reports at https://crash-stats.mozilla.com/report/list?product=FennecAndroid&signature=gfx3DMatrix%3A%3ACanDraw2D%28gfxMatrix*%29+const
Component: Graphics, Panning and Zooming → Graphics: Layers
Product: Firefox for Android → Core
Keywords: reproducible
Hardware: All → ARM
Whiteboard: [native-crash]
tracking-fennec: --- → ?
Why should this track? Is it a regression?
It is an easy to reproduce crash on the phone. May be related to the other ARMv6 top crash bug 845867?
Milan, can we get an assignee?
tracking-fennec: ? → +
Flags: needinfo?(milan)
The 25 (nightly) crashes are all sigsegv, the 22 (release) ones are a mixture of sigill and sigsegv some of which are tagged as "heap corruption" if I'm reading it right.
BenWa, can you take a look?
Assignee: nobody → bgirard
Flags: needinfo?(milan)
If someone can start the ball with a regression window it would make this much easier to solve.
All of these are deferred composites. Perhaps we're not holding a reference and by the time the Runnable executes the object has been freed.
Attached patch patchSplinter Review
Attachment #8390741 - Flags: review?(jmuizelaar)
Attachment #8390741 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/c06738b18379

Let's leave open until we can confirm. It's possible that we have more dangling stuff closer to the LayerManager.
Keywords: leave-open
Looks like the patch resolved the problem.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30
You need to log in before you can comment on or make changes to this bug.