Double digit date does not display on American Airlines page

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
18 years ago
17 years ago

People

(Reporter: christinehoff4, Assigned: rods)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Testing on the following builds:

Windows: 06_25_11_0.9.2
Mac: 07_05_03_0.9.2
Linux: 07_05_10_0.9.2

1. Go to the American Airlines page as indicated above or open the simplified 
attached testcase. 
2. Go to 'Departure Date' day selection on the American Airlines page or the 
second select box in the attached testcase. The problem exists with 2 
select boxes in a table cell.
3. Click a double digit number.

Expected result: The complete number you selected should be displayed.
Actual result: Only the first digit is displayed.

I reduced the problem down to the lowest denominator I could. The table cell 
width is forcing the second select box unto the next line and when it does, the 
second digit does not display. If you increase the width of the cell or do a 
combination of other things, the problem is eliminated.

This is bad for the user, because it looks as if the day they selected is not 
the day they got.

IE is rendering the page properly. Bug is cross platform
(Reporter)

Comment 1

18 years ago
Created attachment 41348 [details]
Simplified testcase to demonstrate the problem
(Reporter)

Updated

18 years ago
QA Contact: petersen → chrisd

Comment 2

18 years ago
WFM on build 2001-07-04-04, Win98.

Both the page and testcase work with no problems.  There are about 3-4
characters of space available, total.

The only thing I was able to see was the dropdown elements did not resize to the
correct height when enlarging text size, but that is a separate (probably
already filed) bug.

Try doing a clean install on each system.  I had some problems with dropdowns
until I wiped everything...I think I had to dump my profile too.
(Reporter)

Comment 3

18 years ago
I reproduced this problem across platform. I always install clean builds so the 
best I can do is to remove the Profile on Win98 and try again. I still get the 
same problem on Mac and Linux.

Comment 4

17 years ago
not a table specific bug, back to the core owner.
Assignee: karnaze → attinasi
QA Contact: chrisd → petersen
Works fine with 2002012203 build on the testcase.
Reassigning to Rod.
Assignee: attinasi → rods
Target Milestone: --- → mozilla1.0
WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.