enabling/disabling quicklaunch should not require a restart

VERIFIED FIXED in mozilla0.9.4

Status

SeaMonkey
UI Design
P2
normal
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: Blake Ross)

Tracking

Trunk
mozilla0.9.4
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Enabling or disabling Quick Launch should not require a restart of the operating
system or the browser.

Steps to reproduce:
1. Enable Quick Launch in Edit->Prefs->Advanced.
2. Close and restart Mozilla.
Result: Mozilla takes a long time to start up.
Expected: Mozilla should restart quickly.

3. Close and restart Mozilla again.

Result: Mozilla takes a long time to start up.
Expected: Mozilla should restart quickly.

4. Close Mozilla.
5. Restart Windows, or run mozilla.exe -turbo.
6. Restart Mozilla.

Result: Mozilla restarts quickly (good).

(Similar steps for trying to disable Quick Launch)
(Reporter)

Updated

17 years ago
Blocks: 75599
turbo/quicklaunch ->vishy, qa: paw/jrgm. bill is on sabbatical...
Assignee: law → vishy
QA Contact: sairuh → paw

Updated

17 years ago
Keywords: nsbeta1

Comment 2

17 years ago
nav triage team:

marking nsbeta1+, p2, and mozilla1.0
Keywords: nsbeta1 → nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
--> me
Assignee: vishy → blaker
Target Milestone: mozilla1.0 → mozilla0.9.4

Comment 4

17 years ago
Created attachment 44898 [details] [diff] [review]
prototype

Updated

17 years ago
Status: NEW → ASSIGNED
r=ccarlen
*** Bug 85437 has been marked as a duplicate of this bug. ***
*** Bug 81715 has been marked as a duplicate of this bug. ***
*** Bug 91221 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 92292
*** Bug 91350 has been marked as a duplicate of this bug. ***
Blake - have we tested all the cases with this bug, if so we shd get it sr'ed 
and speed it into the tree... 

Comment 11

17 years ago
Conrad is working out an issue with his multiple profiles patch; plan is to land
this after he lands to help avoid conflicts.
In your code you have (long exprs replaced):

       rv = GetNativeAppSupport(getter_AddRefs(nativeApp));
-      if (NS_SUCCEEDED(rv) && NS_SUCCEEDED(goats) && moreGoats) {
-        // Create special Nav window.
-        nativeApp->StartServerMode();
-        return NS_OK;
-      }
+      // Create special Nav window.
+      if (NS_SUCCEEDED(goats) && moreGoats) {


What is the relevance now of obtaining the return value in:
rv = GetNativeAppSupport(getter_AddRefs(nativeApp));

if the return value is now never used? I'd say it'd allow you to return the
return value with |return rv| at the end of the function, however subsequent
functions promptly clobber whatever value GetNativeAppSupport returned so it's
not really achieving anything ;) 

Comment 13

17 years ago
Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
Paul: please, like, test the crap out of this :-)  You may want to wait until
multiple profile support lands.  We need to see how changing this pref in one
profile affects the other profiles (we think it's going to be global, and are
okay with that).  It's also critical to see how backwards compatible this is,
i.e. what happens if you used turbo in 6.1 and then upgrade.  I believe we still
need an installer-side fix to make all this work properly.

Comment 15

17 years ago
reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 16

17 years ago
Created attachment 46042 [details] [diff] [review]
I can sleep at night with this patch.
Back to having only one attribute for determining whether we're in server mode
is much better. Some of my code (multiple profile patch) was already tripped up
by the difference. r=ccarlen

Comment 19

17 years ago
Fixed.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
Terri, can you verify this bug for me. I'm up to my ears in reviews. Thanks.
QA Contact: paw → tpreston

Comment 21

17 years ago
Verified W2k build 2001082203
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer blocks: 75599

Updated

17 years ago
Blocks: 75599
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.