If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"ASSERTION: degenerate transform while synthetic bolding" with drawWindow

RESOLVED DUPLICATE of bug 906704

Status

()

Core
Graphics: Text
RESOLVED DUPLICATE of bug 906704
4 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, testcase})

Trunk
x86_64
Mac OS X
assertion, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 777296 [details]
testcase

###!!! ASSERTION: degenerate transform while synthetic bolding: 'm != 0.0', file gfx/thebes/gfxFont.cpp, line 2272
(Reporter)

Comment 1

4 years ago
Created attachment 777302 [details]
stack
This seems to arise during generation of the page thumbnail for Panorama, not the main page drawing.

There's a regression in Nightly where synthetic bolding is no longer handled properly when generating thumbnails; something has changed about the results we're getting when calling

    gfxSize t = aContext->UserToDevice(gfxSize(1.0, 0.0))

in gfxFont::CalcXScale(), and that's what ends up hitting this assertion (and then a divide-by-zero error) in the case where content is rotated exactly 90°.

I'll attach a testcase that demonstrates a visual glitch as a result of this, for rotations that approach 90°.

The regression first appears in Nightly of 2013-07-15.

OK: Nightly 2013-07-14
Built from http://hg.mozilla.org/mozilla-central/rev/18467a85acf6

Bad: Nightly 2013-07-15
Built from http://hg.mozilla.org/mozilla-central/rev/ff0a372e3170

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=18467a85acf6&tochange=ff0a372e3170

Given that this seems to be Mac-only, I'm suspicious that bug 892966 may be involved, though I have not tried backing this out locally to confirm.
Created attachment 779288 [details]
testcase for Panorama synthetic-bold regression

This testcase avoids the exact 90° rotation, so it shouldn't assert or crash, but by opening the Panorama view (Cmd-Shift-E) you can see the synthetic-bolding problem: note the incorrect double-strike of the "a" letters that are rotated to a close-to-vertical orientation.
Yes, it is likely bug 892966. That somewhat unintentionally enables us using CoreGraphics Azure for thumbnail drawing. I expect I have also broken it for the non-drawwindow case with bug 896489.
Bug 906704 is fixing this.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 906704
You need to log in before you can comment on or make changes to this bug.