firefox not displaying our videos correctly

VERIFIED INVALID

Status

()

Core
Plug-ins
VERIFIED INVALID
5 years ago
5 years ago

People

(Reporter: andy@websitetalkingheads.com, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-08-22])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Set your dpi to anything but 100%
visit a site with one of our videos on it(http://www.websitetalkingheads.com/examples.php)
see that the video is still original size and is now not place correctly


Actual results:

Version 22 started using dpi to set display however, our videos didn't get adjusted with the rest of the page.


Expected results:

Video should change size and position based on the dpi settings of the user, just like everything else on the page.

Comment 1

5 years ago
Dupe Bug 891955 ?
(Reporter)

Comment 2

5 years ago
Have never received any feedback on previous report and it is now closed
Would like some kind of response on this please
(Reporter)

Comment 3

5 years ago
Looks like the issue is with the document.write function.  The div tag and the contents of the div are create with document.write If I use the exact same variables and set the div tag's variable using document.getElementById the error appears to go away.

Comment 4

5 years ago
These videos are Flash, so moving to Core::Plug-ins for further triage.
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Comment 5

5 years ago
If I turn off flash and it goes to our html5 fallback and those are the right size and position.

Comment 6

5 years ago
Could you please do some additional debugging? In particular, are the computed sizes of the Flash elements (according to the DOM) correct? In your actionscript in Flash, what are the reported sizes of the content?

It is likely that this is a bug either in your .swf files (not scaling to fit the actual size of the DOM element) or in the Flash player, but without more investigation it's hard to do much more with this.
Flags: needinfo?(paris_giovanni)
Whiteboard: [closeme 2013-08-22]
(Reporter)

Comment 7

5 years ago
According to Dom Inspector the object (our swf) created is the size that we set.
  
Here is how we determine the size of the video on the page.  
  1- We render video to client's specifications.
  2- We create a js file that controls the swf as well as the html5 fallback.  The Height and Width of the video are put in the js file as variables.
  3- The js file creates a div tag on the page based on the variables. 
  4- Then an object is created.  This object is a swf and its size is the same as the div size, which is based on the video size.

The sizes for everything is based on the variables in the js file which are based on the rendered size of the video.

I did check a couple other elements on the same page as one of our videos.  And the dom reports them as the same size as the HTML sets them as.  MeasureIt reports the sizes as the same as coded in the HTML but that is obviously not correct.  So I took a screenshot and one image that is 400x285 turns out to be about 500x356 and another that is 96x210 is actually 120x262.  Our video measured in the screenshot is the same as it is set in the HTML.

So from my end it looks like for some reason Firefox isn't magnifying the video object like it is other images and such on the screen.

I checked out more than a dozen of our competitors and a couple had this issue as well.  However, everyone that didn't have the issue had very poor video quality.  Probably caused by the video being blown up 125%.

So, I am not quite sure I answered the question.  The size reported in the dom of the object is the correct size which is based on the rendered size of the video.  In our actionscript the size of the content is the size set in the js file, which is the rendered size of the video.
It just seems that Firefox isn't magnifying it like it does other objects on the page.
Flags: needinfo?(paris_giovanni)

Comment 8

5 years ago
The size that's reported in the DOM is in CSS pixels. There are several things which can affect the mapping of CSS pixels to device pixels, including the zoom level chosen by the user.

We inform Flash of the actual dimensions of the plugin box and then it's typically the job of the ActionScript in your .swf file to scale your video to fit the frame.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

5 years ago
Not sure why this bug's status keeps getting set to resolved.
It is not resolved.
Also didn't receive the last email to this.
This issue didn't occur until update to include DPI scaling.  

Yes we inform Flash of the actual dimensions.  I have never seen anything about  ActionScript resizing a video based on the browser that it is playing in.  
Can you show me some code that would do this?  Because I have searched extensively and only found ways to resize a flash video when it is full screen.
These videos are not full screen, they are small, usually 320x320.  The exact size is sent to flash and it plays the exact size.  
It is just that now after the update, Firefox doesn't magnify them.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.