[B2G][l10n][Marketplace] [sr-Cyrilic]: Localization needed for 1.1 release

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: CocoMo, Assigned: auzelac91)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Opening the bug to track progress of sr-Cyrilic translation.  I will open a separate bug on sr-Latin conversion.

Hi Milos, 

I know you have been super busy with other requests so this has not been a high priority.  There is a huge backlog in the Zamboni section, so if work doesn't start sooner, you will have a lot to catch on later.  

Translation: Component, Priority and String Pickup Location:
===========
Marketplace consists of 3 components, Fireplace being the most important one and Zamboni as the legacy DB.  Zamboni is being revamped and redesigned.  The work is ongoing.
* P1: Fireplace - frontend, and consumer pages: https://github.com/mozilla/fireplace/tree/master/locale
* P2: Webpay - payment system: https://github.com/mozilla/webpay/tree/master/locale 
* P3: Zamboni (legacy): http://viewvc.svn.mozilla.org/vc/addons/trunk/site/app/locale/ 

For testing:
==========
* Overall test site: https://marketplace-dev.allizom.org/?lang=xx; for phones, change settings
* Webpay-paid apps: https://marketplace-dev.allizom.org/?lang=xx/search?q=pricepoint/
(Reporter)

Updated

6 years ago
Assignee: nobody → bdjuric
(Reporter)

Comment 1

5 years ago
Hi Milos,

Fireplace and webpay needs to be done so the marketing components can be completed.  Please deligate it to other people if this can't be done by you.  sr is really behind.

Oskar, 
I hope you can help out with this effort. I am cc'ing on the task.  This task blocks the completion of another bug on the screenshots bug 899253.  

Thank you,
Peiying
Blocks: 899253
Status: NEW → ASSIGNED
(Reporter)

Updated

5 years ago
Blocks: 903145
(Reporter)

Comment 2

5 years ago
zamboni is moved to https://github.com/mozilla/zamboni/tree/master/locale so they are all on github now.
Done with Fireplace. Made https://github.com/mozilla/fireplace/pull/235 .
(Reporter)

Comment 5

5 years ago
Thank you so much!!  I will have Wil Clouser make a push so you can test it.  

Also, can you make a conversion to sr-Latin?  Marketing components require that Marketplace shows up in both charactersets.  

Thanks,
Peiying
In both pushes I added Cyrillic and Latin, so we're good on both fronts.
How can I translate marketplace only without needing to translate whole AMO?
(Reporter)

Comment 8

5 years ago
Hi Milos,

AMO is managed by Amy Tsai.  There might be some commonly shared files, but Marketplace, has its own code base from what I know. It also has new strings added on a regular basis.

AMO is on maintenance mode as the plan was to transition to marketplace, but this has not happened.  How is AMO in sr?
WRT AMO in sr, very low percentage of strings are translated. Mind pinging Amy to let us know where can I get strings from and I'll get onto it.
Duplicate of this bug: 895164
Assignee: bdjuric → milos
Flags: needinfo?(atsay)

Comment 11

5 years ago
AMO and Marketplace share the same code base. As far as I know they need to be translated together, but clouserw can confirm.
Flags: needinfo?(clouserw)
(In reply to Amy Tsay [:amyt] from comment #11)
> AMO and Marketplace share the same code base. As far as I know they need to
> be translated together, but clouserw can confirm.

yup
Flags: needinfo?(clouserw)
(Reporter)

Comment 13

5 years ago
Wil, is there a separate repository for AMO aside from those in github for fireplace, webpay and zamboni?
AMO is entirely contained in the zamboni repository
Note: I started on AMO in Verbatim.
(Reporter)

Updated

5 years ago
Assignee: milos → oskar.ivanic
Flags: needinfo?(atsay) → needinfo?
(Reporter)

Updated

5 years ago
Flags: needinfo?
(Reporter)

Comment 16

5 years ago
Hi Oskar,

There are updates once every so often in Fireplace and Webpay. You should focus on finishing up these first.  Then you can work on zamboni when you prioritize between other requests.  We do need to get zamboni done, but it is a large database and it will take a while to complete.  

Thank you,
Peiying
(Reporter)

Comment 17

5 years ago
Hello Oskar,

Feel free to add contributors to this bug to help distribute the workload.  Quite a bit of work needs to be done.  

New strings have been added since the repos were updated and new component is also added as well.  In the order or priority, please find the components and  the locations here:

P1: Fireplace: frontend, and consumer pages: https://github.com/mozilla/fireplace/tree/master/locale
P2: Webpay: payment system: https://github.com/mozilla/webpay/tree/master/locale 
P3: Zamboni (legacy): https://github.com/mozilla/zamboni/tree/master/locale
P4: Commbadge: (developer communication dashboard) https://github.com/mozilla/commbadge/tree/master/locale

You can check the progress here: http://l10n.mozilla-community.org/~flod/mpstats/.  It is updated daily.

Let me know if you need additional information.

Thank you,
Peiying
Assignee: oskar.ivanic → auzelac91
(Reporter)

Comment 18

5 years ago
I will mark this one fixed.  There are still a lot of strings to be localized but it is an ongoing project.  Please keep an eye on the weekly status email from the Marketplace dev team.  In addition, you can track the status here: http://l10n.mozilla-community.org/~flod/mpstats/

Also for those not comfortable using github, contributors can go to verbatim to localize:
p1 front end: https://localize.mozilla.org/projects/fireplace/
p2 payment: https://localize.mozilla.org/projects/webpay/
p3 payment processor: https://localize.mozilla.org/projects/zippy/
p4 Zamboni (AMO): https://localize.mozilla.org/projects/amo/
p5 communication dashboard: https://localize.mozilla.org/projects/commbadge/
p6 publishing tool for developer: https://localize.mozilla.org/projects/rocketfuel/

The marketplace product is now serving both the FFOS, Android and desktop users.  Please get it up to date as frequently as possible.  Thank you.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.