WebAudio crash [@mozilla::dom::AudioListener::UnregisterPannerNode]

RESOLVED DUPLICATE of bug 894150

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 894150
6 years ago
6 years ago

People

(Reporter: posidron, Unassigned)

Tracking

(Blocks 1 bug, {assertion, crash})

Trunk
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [blocking-webaudio-])

Attachments

(2 attachments)

Reporter

Description

6 years ago
Posted file callstack
I am hitting this crash fairly often but am unable to get a testcase for it.

###!!! ASSERTION: You can't dereference a NULL nsRefPtr with operator->().: 'mRawPtr != 0', file ../../../dist/include/nsAutoPtr.h, line 1028

Tested with http://hg.mozilla.org/integration/mozilla-inbound/rev/130d254e9e44
Reporter

Comment 1

6 years ago
Posted file testcase
Okay, got one. It takes a few seconds (15 - 20) before it triggers this way.
Reporter

Updated

6 years ago
Keywords: testcase-wanted
I can't repro on current tip, and it is pretty likely to have been fixed by [1].

http://hg.mozilla.org/integration/mozilla-inbound/rev/31b881b4b960

Comment 3

6 years ago
Christoph, can you please retest?
Flags: needinfo?(cdiehl)
Reporter

Comment 4

6 years ago
True, got fixed!
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(cdiehl)
Resolution: --- → FIXED

Comment 5

6 years ago
Gotta love it when we fix bugs before they're reported.  ;-)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 894150

Updated

6 years ago
Whiteboard: [blocking-webaudio-]
You need to log in before you can comment on or make changes to this bug.