[Buri][MMS][GCF] Client didn't support page timing in retrieval mode.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Reporter)

Description

5 years ago
SW171
 AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.152
 Firefox os  v1.1
 Mozilla build ID:20130702230206
 DEFECT DESCRIPTION:
 Client didn't support page timing in retrieval mode.
 
  REPRODUCING PROCEDURES:
 From the pics:
 ics_page_timing_retrieval	Client supports page timing in retrieval mode	
 
 1. Receive a mms with multi pages with different page timing.
 2. Read the mms, find it just display the content, will not display the sildshow with page timing->ko
 
  EXPECTED BEHAVIOUR:
 
 Client should support page timing in retrieval mode.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 100%
 
  For FT PR, Please list reference mobile's behavior:

Comment 1

5 years ago
It's a block certification problem.

Updated

5 years ago
blocking-b2g: --- → leo?
Slideshow playback is not in the v1.1 scope. ni? PM for confirmation.
Flags: needinfo?(wchang)
please change PICS to not support to unblock certification. will this be ok? thank you
Flags: needinfo?(sync-1)
(In reply to Joe Cheng [:jcheng] from comment #3)
> please change PICS to not support to unblock certification. will this be ok?
> thank you

I agree we should go with no support. 
flagging product here.
Flags: needinfo?(wchang) → needinfo?(ffos-product)

Comment 5

5 years ago
(In reply to Wayne Chang [:wchang] from comment #4)
> (In reply to Joe Cheng [:jcheng] from comment #3)
> > please change PICS to not support to unblock certification. will this be ok?
> > thank you
> 
> I agree we should go with no support. 
> flagging product here.

I have no idea about PICS. Can you kind enough to give me a more detailed description?

Updated

4 years ago
Flags: needinfo?(jcheng)
Hi Tianm, Cheng-an would know. I responded to him over email. It's the feature declaration form. Thanks
Flags: needinfo?(jcheng)

Comment 7

4 years ago
(In reply to Joe Cheng [:jcheng] from comment #6)
> Hi Tianm, Cheng-an would know. I responded to him over email. It's the
> feature declaration form. Thanks

OK.
Flags: needinfo?(sync-1)
It sounds like there's agreement to not block on this.  Please renom if I'm mis-interpreting.
blocking-b2g: leo? → -
(Reporter)

Updated

4 years ago
blocking-b2g: - → koi?
Moving NI to Wilfred.
Flags: needinfo?(ffos-product) → needinfo?(wmathanaraj)
adding to backlog 891754
Blocks: 891754
blocking-b2g: koi? → ---
this is planned as part of v1.3
Flags: needinfo?(wmathanaraj)

Comment 12

4 years ago
We can't waive it this time. What's about the advance about this pr now?
blocking-b2g: --- → 1.3?
(In reply to 田旻 from comment #12)
> We can't waive it this time. What's about the advance about this pr now?

Wilfred - What do you want to do here?
blocking-b2g: 1.3? → -
Flags: needinfo?(wmathanaraj)
Opps, meant to leave that nomed.
blocking-b2g: - → 1.3?
This is a big feature and won't likely be done for 1.3 nor 1.4.
SMIL /PICS support is a big feature. I assume this is for partner certification that has been raised. If there is any partner who is willing to contribute to it we can take this up but for now we would backlog this issue as part of future enhancements contributors and provide.

We have no plans at the moment to work on these MMS features.
blocking-b2g: 1.3? → backlog
Flags: needinfo?(wmathanaraj)

Comment 17

4 years ago
Dears, 

This feature is in PICS and it becomes GCF blocking issue, so what to do in next step?

Updated

4 years ago
Flags: needinfo?(vchen)
I am sorry, currently we really don't have any plan to support this, even if we do, it might take quite a while to implement this feature. So could you just update PICS to "not support" for Sora?

Thanks

Vance
Flags: needinfo?(vchen)
I even think UX does not want that we implement this at all, because it brings small value. I even know people that don't like that other devices support this, because this makes reading a MMS slow.

Ayman, can you comment here?
Flags: needinfo?(aymanmaat)

Comment 20

4 years ago
(In reply to Julien Wajsberg [:julienw] from comment #19)
> I even think UX does not want that we implement this at all, because it
> brings small value. I even know people that don't like that other devices
> support this, because this makes reading a MMS slow.
> 
> Ayman, can you comment here?

I have no real comment to add on top of what has already been said in this thread. Historically slideshow never became part of the formal requirements for the reasons you state in comment 19. The feature was at one point suggested, but was dropped very early prior to V1 and no design work was ever carried out on it.
Flags: needinfo?(aymanmaat)
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
We don't want to implement this.

If there is enough request from our users, we may change our mind, but so far nobody asked us.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.