Adding a CSS transition delay causes content to show through

RESOLVED WONTFIX

Status

Firefox OS
General
RESOLVED WONTFIX
5 years ago
4 months ago

People

(Reporter: marcosc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [perf-reviewed], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:25.0) Gecko/20130716 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130716030202

Steps to reproduce:

Open the following URL on a device:
http://marcoscaceres.github.io/playground/splashscreens/delay.html


Actual results:

When the first animation plays, the background content shows through the foreground (you will see a flash of content). 


Expected results:

The content in the background should be revealed as the top layer fades out.
(Reporter)

Updated

5 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → Other
Didn't David conclude that this could be because of off the main thread animations?
Flags: needinfo?(dzbarsky)
Sure, that's possible.  However, I couldn't reproduce it in a nightly Mac build with OMTC+OMTA enabled.  We should try on the device with OMTA disabled.
Flags: needinfo?(dzbarsky)
(In reply to David Zbarsky (:dzbarsky) from comment #2)
> Sure, that's possible.  However, I couldn't reproduce it in a nightly Mac
> build with OMTC+OMTA enabled.  We should try on the device with OMTA
> disabled.

Marcos, can you do that?
Flags: needinfo?(mcaceres)
Note that there's no way to do that from the UI so you have to flash your own gecko.
(Reporter)

Comment 5

5 years ago
I could try, but given that I've never done it before it would probably take me far longer to do it right than it would take David or someone else.
Flags: needinfo?(mcaceres)
Whiteboard: [perf-reviewed]

Comment 6

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.