Missing Characters when displaying PDF in FireFox (FF) PDF Viewer

RESOLVED FIXED

Status

()

Firefox
PDF Viewer
P4
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ken.roe, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Created attachment 777873 [details]
This screen shot shows the missing letter "b".

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

We use a third party tool for our PDF generation (ABCpdf). Our PDFs render correctly (as viewed in the browser) for all browsers, except FF.
We have seen this issue using the following system specs...
System 1:
-Win7 Ultimate, 64Bit
-FF 22.0
-Adobe Acrobat plug-in (10.1.7.27)

System 2:
Win7 Pro, 32Bit
FF 22.0
Funnelcake July 2012
Mosilla14-1.0
Adobe Acrobat plug-in (10.1.1.33)

A fix that was found to work, BUT ONLY FOR SYSTEM 1, was to...
1. Disable Adobe Acrobat plug-in
2. Restart FF
3. Open the PDF in FF, generated correctly
4. Enable the Adobe plug-in
5. Restart FF
6. Open the PDF in FF, generated correctly

Possible related or duplicated tickets...
https://bugzilla.mozilla.org/show_bug.cgi?id=862313
https://bugzilla.mozilla.org/show_bug.cgi?id=863996
https://bugzilla.mozilla.org/show_bug.cgi?id=876172
https://bugzilla.mozilla.org/show_bug.cgi?id=878891


Actual results:

All letter "b" were missing from the document when using the FF in-app PDF viewer.  If I click "download", then open the document in Adobe Acrobat, it looks as expected.  In addition, some users have reported that negative signs "-" were displaying as squares.  If the user highlights the text with the missing character(s), and sets focus outside of FF, the missing characters show up in the highlight text.  Then, the characters disappear when focus is set back to FF.  Users are in the habit of using the ptint functionality within the FF PDF viewer.  When they use this (instead of downloading and then printing), the characters are missing in the printed copy.


Expected results:

The viewer should have displayed a PDF containing all expected characters.

Comment 1

5 years ago
Could you attach a PDF sample, please, so we will be able to test.
Component: Untriaged → PDF Viewer
Flags: needinfo?(ken.roe)

Updated

5 years ago
Priority: -- → P4
Whiteboard: [pdfjs-f-need-info]
(Reporter)

Comment 2

5 years ago
Created attachment 779386 [details]
Here is an example of a PDF that is missing the letter "b".  You can see that starting on page 9, question 20, the "b"s are missing from the answer choices.
Flags: needinfo?(ken.roe)

Comment 3

5 years ago
(In reply to ken.roe from comment #2)
> Created attachment 779386 [details]
> Here is an example of a PDF that is missing the letter "b"

Which page?
Flags: needinfo?(ken.roe)
(Reporter)

Updated

5 years ago
Attachment #779386 - Attachment description: Here is an example of a PDF that is missing the letter "b" → Here is an example of a PDF that is missing the letter "b". You can see that starting on page 9, question 20, the "b"s are missing from the answer choices.

Comment 4

5 years ago
It's an issue with your PDF generator that creates bad PDFs. I read your sample with various PDF reader (Firefox, Nuance PDF, SumatraPDF) on various machines (XP, Win 7), I observed the same rendering issue. The letter "b" is not rendered because it's missing in the PDF.
Flags: needinfo?(ken.roe)
(Reporter)

Comment 5

5 years ago
(In reply to Loic from comment #4)
> It's an issue with your PDF generator that creates bad PDFs. I read your
> sample with various PDF reader (Firefox, Nuance PDF, SumatraPDF) on various
> machines (XP, Win 7), I observed the same rendering issue. The letter "b" is
> not rendered because it's missing in the PDF.

This does not look to be an issue in the PDF generation. The attachment is a scanned image of the PDF that was printed using the FF PDF viewer.  There is no way, that I know of to save the PDF exactly as it is in the FF PDF viewer.  When viewing the generated PDF in the FF PDF Viewer, if I highlight the problem text, then set focus somewhere outside of the FF browser, the highlighted text displays the missing characters.  Also, if I download the PDF using the download button on the FF PDF viewer, and open the downloaded PDF in Adobe Acrobat, the characters are not missing.  If I perform this same action using IE or Chrome, the PDF displays correctly in both browsers.

I will add an attachment for the PDF that was downloaded and saved using the FF PDF Viewer.
(Reporter)

Comment 6

5 years ago
Created attachment 779877 [details]
PDF sample (see page 9, question 20, letter "b" is missing)

This is the actual PDF when is is viewed in the FF PDF viewer, then downloaded and saved.  When the PDF is downloaded from the viewer, the characters are not missing.

Comment 7

5 years ago
Yes, we don't need the scanned version of the PDF, but the original PDF showing the issue. Without that, we can't fix eventually the rendering bug.

Updated

5 years ago
Attachment #779386 - Attachment is obsolete: true

Updated

5 years ago
Attachment #779877 - Attachment filename: FF_PDF_Downloaded_and_Saved_from_FF_PDF_Viewer.pdf → PDF sample (see page 9, question 20, letter "b" is missing)

Updated

5 years ago
Attachment #779877 - Attachment description: FF_PDF_Downloaded_and_Saved_from_FF_PDF_Viewer.pdf → PDF sample (see page 9, question 20, letter "b" is missing)
Attachment #779877 - Attachment filename: PDF sample (see page 9, question 20, letter "b" is missing) → FF_PDF_Downloaded_and_Saved_from_FF_PDF_Viewer.pdf

Comment 8

5 years ago
I tried the PDF sample with FF25, issue confirmed ("b" is missing).
No error message in the web console.

[20:20:16.598] "PDF b56a9573bb7a49be27842daf69298d26 [1.4 Interactive Achievement via ABCpdf / onTRAC by Interactive Achievement] (PDF.js: 0.8.291)"
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

5 years ago
Sorry, with FF23 (*I'm tired*).

Comment 10

5 years ago
It's fixed in FF24+ by:
Ryan VanderMeulen — Bug 871530 - Update pdf.js to version 0.8.169. r=dtownsend

You can download Aurora to confirm if you want.
http://www.mozilla.org/en-US/firefox/all-aurora.html
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 871530
Resolution: --- → FIXED
Whiteboard: [pdfjs-f-need-info]
You need to log in before you can comment on or make changes to this bug.