[Mac and Linux] Custom distribution settings for yahoo de and es distributions are not being set

RESOLVED FIXED in Firefox 23

Status

()

Firefox
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Trunk
Firefox 25
x86_64
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox22+ wontfix, firefox23+ fixed, firefox24+ fixed, firefox25 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

+++ This bug was initially created as a clone of Bug #882989 +++

Spinoff of bug 882989 for Mac and Linux.

The only method I can think of to fix on Mac and Linux this would be in the distribution code itself. This should be possible since on Mac and Linux we currently don't update unless the user updating has write access to the installation directory so after updating the user should have write access and the distribution.ini file can be encoded as utf-8 in distribution.js.

The error being thrown is:

Zeitstempel: 6/13/2013 5:50:05 PM
Fehler: [Exception... "Could not convert Native argument arg 2 [nsIINIParser.getString]"  nsresult: "0x8057000a (NS_ERROR_XPC_BAD_CONVERT_NATIVE)"  location: "JS frame :: resource://app/modules/distribution.js :: DIST_applyPrefDefaults :: line 269"  data: no]
Quelldatei: resource://app/modules/distribution.js
Zeile: 269
One option that would protect against future encoding issues that would get us most of the way there would be to try / catch these calls. Then all but the name and name.AB_CD (e.g. yahoo.de) values would get set.
Created attachment 778003 [details] [diff] [review]
wallpaper patch rev1

Hey Gavin, I came up with a wallpaper patch that should allow partner distributions with this bug to continue to work though the Partner's about string will not be display.
Attachment #778003 - Flags: review?(gavin.sharp)
Comment on attachment 778003 [details] [diff] [review]
wallpaper patch rev1

Looks fine to me, but mconnor said he'd review this on IRC.
Attachment #778003 - Flags: review?(gavin.sharp) → review?(mconnor)
tracking-firefox23: --- → ?
tracking-firefox24: --- → ?
status-firefox22: --- → affected
status-firefox23: --- → affected
status-firefox24: --- → affected
Comment on attachment 778003 [details] [diff] [review]
wallpaper patch rev1

r=me if you add a Cu.reportError(e); in the first try/catch.

I suspect a lot of this file could use defensive coding.
Attachment #778003 - Flags: review?(mconnor) → review+
Created attachment 778633 [details]
wallpaper patch rev2 comments addressed

addressed comment and carrying forward r+
Assignee: nobody → robert.bugzilla
Attachment #778003 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #778633 - Flags: review+
Comment on attachment 778633 [details]
wallpaper patch rev2 comments addressed

[Approval Request Comment]
Bug caused by (feature/regressing bug #): No Bug. Specific partner distributions have been shipping ANSI encoded distribution.ini files which is incorrect.
User impact if declined: The affected partner distribution won't have all of their customizations set.
Testing completed (on m-c, etc.): Tested locally. Very little value in testing on m-c, etc. since this bug only affects these partner distributions.
Risk to taking this patch (and alternatives if risky): Low. The patch simply wraps the calls that throw in a try / catch
String or IDL/UUID changes made by this patch: None
Attachment #778633 - Flags: approval-mozilla-beta?
Attachment #778633 - Flags: approval-mozilla-aurora?
tracking-firefox23: ? → +
tracking-firefox24: ? → +
Attachment #778633 - Flags: approval-mozilla-beta?
Attachment #778633 - Flags: approval-mozilla-beta+
Attachment #778633 - Flags: approval-mozilla-aurora?
Attachment #778633 - Flags: approval-mozilla-aurora+
Pushed to mozilla-aurora
https://hg.mozilla.org/releases/mozilla-aurora/rev/51b93baa190b

Pushed to mozilla-beta
https://hg.mozilla.org/releases/mozilla-beta/rev/bc0f5e676268
status-firefox22: affected → fixed
status-firefox23: affected → fixed
Target Milestone: --- → Firefox 25
status-firefox22: fixed → wontfix
status-firefox24: affected → fixed
status-firefox25: --- → fixed

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/1273e2556a0f
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Depends on: 900925
You need to log in before you can comment on or make changes to this bug.