Bluetooth app tries to handle Share URL activity and fails

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: benfrancis, Assigned: iliu)

Tracking

({productwanted})

unspecified
productwanted
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
STR:

* Open browser app
* Navigate to a web site
* Click the share button in the bottom toolbar

Expected:
* Bluetooth app handles the activity correctly or not at all

Actual:
Bluetooth app tries to handle the web activity and shows an error saying that it failed
Keywords: productwanted
Sharing url to other bluetooth devices is not in the previous scope. I would like to handle the issue with not at all. It will need to add some filter for excluding type 'url' in the manifest. But the share button will be useless in the bottom toolbar. It should be grey out or do some other interaction. I don't know the user story for the share bottom in Browser app.

Then, we can create another issue for the feature. We should share the 'url' like a text file to other devices. It will need a discussion.
Bug 897375 - Bluetooth app supports to handle Share URL activity to other devices
Assignee: nobody → iliu
Adding needinfo on product per productwanted request.
Flags: needinfo?(ffos-product)
Ah, I think I'm having this issue.

I'm trying to share a image generated in my app, and even if the blob is "perfect" (I can build a URL and navigate to that URL, and it shows the image properly), I am getting a "Bluetooth file transfer failed. Check that the Bluetooth settings are correct" message.

From what I read in this bug description, since I am trying this on a brand new phone and I haven't installed any apps other than mine, I figure that there are no other applications with support for the sharing activity other than the Bluetooth app, and it's failing at handling the activity-maybe I haven't configured Bluetooth?

Is there any way to see what apps are registered as supporting the share activity?

I'd suggest either show the list of available apps or at least have the Bluetooth app not fail with such a strange message.
(In reply to Ian Liu [:ianliu] from comment #1)
> Sharing url to other bluetooth devices is not in the previous scope. I would
> like to handle the issue with not at all. 

This sounds like the right approach until this feature is fully implemented.
Flags: needinfo?(ffos-product)
(Reporter)

Updated

5 years ago
Blocks: 915270
(Reporter)

Comment 5

5 years ago
Blocks a koi+ bug
blocking-b2g: --- → koi?
> Sharing url to other bluetooth devices is not in the previous scope. I would
> like to handle the issue with not at all. 

While the feature isnt implemented the bluetooth applications needs to not be registered as being able to receive the share activity invoked with a url, thats what this bug is
(In reply to Dale Harvey (:daleharvey) from comment #6)
> > Sharing url to other bluetooth devices is not in the previous scope. I would
> > like to handle the issue with not at all. 
> 
> While the feature isnt implemented the bluetooth applications needs to not
> be registered as being able to receive the share activity invoked with a
> url, thats what this bug is

If so, that should just be a one or two line change to the manifest file to add a filter on the type field.

Ideally, "Bluetooth" should only show up in the menu for types that the bluetooth app actually knows how to share.
Looks like the bluetooth app ignores the type of the activity request and will handle any share request that has an array named blobs.

So I think you ought to be able to add a filter to the manifest that makes 'blobs' a required property. That way, bluetooth will only be listed when the activity request includes that property.
Created attachment 808412 [details]
Pointer to Github pull request 12486.html

According to Comment 8, add correct filter "type" and "blobs" required for supported "share activity" of Bluetooth app.

David,

Could you please help to review the patch? Thank you so much.
Attachment #808412 - Flags: review?(dflanagan)
Comment on attachment 808412 [details]
Pointer to Github pull request 12486.html

The code looks good to me, but I did not test it. Assuming you have tested it, it looks good to land.
Attachment #808412 - Flags: review?(dflanagan) → review+
I have done manual test for sharing picture/music/video/contacts via Bluetooth. It's working fine for me. Thanks for David's reviewing effort.

Gaia/master:  db54b9d0de74307ad50764cf713662a8de50946a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 915270
reverted here: https://github.com/mozilla-b2g/gaia/commit/9563c38e0cd3fbaaec2a40cd525baf7df5098f2f

This fails a gaia integration test
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 808412 [details]
Pointer to Github pull request 12486.html

><!DOCTYPE html>
><html>
>  <head>
>    <meta charset="utf-8" />
>
>    <title></title>
>
>    <meta http-equiv="refresh" content="0;url=https://github.com/mozilla-b2g/gaia/pull/12486" />
>
>  </head>
>
>  <body>
>
>    Redirecting to => https://github.com/mozilla-b2g/gaia/pull/12486
>
>  </body>
></html>
Attachment #808412 - Attachment description: Pointer to Github pull request 12355.html → Pointer to Github pull request 12486.html
Attachment #808412 - Attachment filename: Pointer to Github pull request 12355.html → Pointer to Github pull request 12486.html
Attachment #808412 - Flags: review?(gaye)
Comment on attachment 808412 [details]
Pointer to Github pull request 12486.html

Obsolete the attachment. I will create another one.
Attachment #808412 - Attachment is obsolete: true
Attachment #808412 - Flags: review?(gaye)
Created attachment 810929 [details]
Pointer to Github pull request 12486.html

Hi Gareth,

Could you please help to review the integration test section? I remove one step(click E-Mail button from share menu), since there is only one share url activity supported. Thanks.
Attachment #810929 - Flags: review?(gaye)
Comment on attachment 810929 [details]
Pointer to Github pull request 12486.html

LGTM! Thanks Ian!
Attachment #810929 - Flags: review?(gaye) → review+
Gareth,

Thanks for your reviewing effort. And sorry for breaking integration test before.

Since the pr is merged, we can close the issue now. 
Gaia/master: ab8fbea15b80297105f63efd7c55c24460ac555c
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
blocking-b2g: koi? → koi+
Keywords: verifyme

Comment 19

5 years ago
Verified fixed on Buri m-c

- works as supposed to per comment 16 - //Since share url via email is supported only, email share url activity handles the request directly.

Gaia   959ac2f692d85072ffdc3d16a041b5bf4735ae59
SourceStamp aa986b6ce882
BuildID 20131010040202
Version 27.0a1
Status: RESOLVED → VERIFIED

Updated

5 years ago
Keywords: verifyme
Uplifted ab8fbea15b80297105f63efd7c55c24460ac555c to:
v1.2: dd4b941d389baf27413f52910a4c3f66aa233bbc
status-b2g-v1.2: --- → fixed
Fix verified on Buri 1.2 mozilla RIL.  Tapping the share button while in a browser site will open an email with a link to that site.

Build ID: 20131017004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/7ca5d1e81d37
Gaia: dbcc171eae6b4d9d168a48291d5ea54c7580561a
Platform Version: 26.0a2
status-b2g-v1.2: fixed → verified

Updated

5 years ago
Depends on: 981626
You need to log in before you can comment on or make changes to this bug.