orientation lock is lost when app is resumed

RESOLVED DUPLICATE of bug 873668

Status

RESOLVED DUPLICATE of bug 873668
5 years ago
5 years ago

People

(Reporter: jlong, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I have an app that I want *only* used in landscape mode. I'm using the `mozLockOrientation` API which seems to work:

`screen.mozLockOrientation('landscape-primary')`

The problem is that if I press the home button, and open up the app again, it isn't locked anymore. It will rotate to whatever orientation the device is in, which makes that API kind of pointless.

The app that does this is: https://marketplace.firefox.com/app/webfighter?src=search (you must set your region to Spain to see it because it uses payments)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873668
You need to log in before you can comment on or make changes to this bug.