[dev][stage] mailto links have been removed from results pages (profiles)

VERIFIED FIXED

Status

Participation Infrastructure
Phonebook
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Details

(Whiteboard: [dev][stage][regression], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 778123 [details]
qa - screenshot of bug on stage

Bug 891230 documented the removal of the mailto link when a user views their own profile.

Did we intend to remove the mailto link from profile pages that are /not/ the user's own page?

Steps to reproduce:
1. goto https://mozillians.allizom.org/en-US/u/rebecca/ (assuming you are not rebecca)

Expected:
Rebecca's email address should be a mailto link

Actual:
It is not

<ul>
  <li class="u-email email">
  <i class="icon-envelope"></i>
  rbillings@mozilla.com
</li>
Confirmed regression. We did not intend this.
Actually I believed that we did intend to do this, but if you feel strongly about it let's go for it.

My argument against it, is that I believe people don't configure their browsers to handle mailto links with their web mail providers and when they click on mailto's they just wait a couple of seconds to see Outlook configuration wizard to appear.

So I'm not saying mailto links are bad or that everybody on the planet is on MS Windows, but maybe they tend to confuse more users than the problem they solve.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
(In reply to Giorgos Logiotatidis [:giorgos] from comment #2)
> Actually I believed that we did intend to do this, but if you feel strongly
> about it let's go for it.

Thanks Giorgos, in honesty I don't feel strongly about it :-) Just something I noticed. It seemed relevant since we hyperlink the irc server.
Indeed we link irc:// so it makes sense to link mailto://.
(Reporter)

Comment 6

5 years ago
QA verified on prod - email addresses returned with search results are linkified with mailto://
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.