OS/2 only - Mail crashes on PII 233

VERIFIED FIXED

Status

MailNews Core
Backend
--
critical
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Christoph.Vogelbusch, Assigned: Scott MacGregor)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.2) Gecko/20010629
BuildID:    

This BUG only happends on one of four Systems. The difference between the
Systems is mainly that the System is older and Mozilla has been first installed
with 0.9.2.
That means the main difference with the other systems is:
no previous installation (if old files e.g. from 0.9.1 are needed)
no MOZILLA_HOME setting
no seperat gcc*.dll
(the last both had been installed for older versions of mozilla and have never
been deleted)

Mozilla works fine, as long as the Mailpart is closed. 3-5 minutes after the
opening of the Mailpart (even if not used and only left open) Mozilla exits and
a white system messaage appears:
"Unknown Title"
Session ID=018
(or Session ID=020)
SYS 3175
At 1D853DF5
mailnews.dll 0001:00034df5


Reproducible: Always
Steps to Reproduce:
Can only be reproduced on that system.
Open mozilla -> open Mailpart -> dosomething or nothing and it crashes after 3-5
minutes.
(system description partly above. Rest:
P2 233, Matrox Milennium, SCSI Adaptec, RTL80139 FastEthernet no sound.

Actual Results:  crash with message above

Expected Results:  -

Updated

17 years ago
Severity: normal → critical
Keywords: crash
maybe OS/2 only.
I don't know what Session ID=018 means. 
A "help sys 3175" (is this working ??) may be useful.
CC: mkaply

Comment 2

17 years ago
Need a talkback id and or stacktrace for this to be useful.
Keywords: stackneeded

Comment 3

17 years ago
We don't have talkback on OS/2.

Reporter, could you please place the crash information from POPUPLOG.OS2?

Thank you
(Reporter)

Comment 4

17 years ago
I tried to answer your posting, but tried it via mail (wich returned), so here
is what I wrote:
-- #1st mail
I only have a german OS/2 here, so may be someone from the OS/2 coding 
can give information. In german it says:(the most important word to you 
are in the middle of the text and are in english in the brackets): 

SYS3175: Bei einem Programm in dieser Sitzung ist ein Fehler aufge-
treten. Das Programm kann nicht fortgesetzt werden.

ERKLÄRUNG: Bei dem Versuch, Daten in eine unzugängliche
Speicheradresse zu laden bzw. dort zu speichern oder eine
unzugängliche Instruktion auszuführen, wurde eine Ausnahmebedingung
(access violation exception) generiert. Dies entspricht dem
allgemeinen Zugriffsfehler für den Intel 80386-Prozessor (#13), der
durch einen ungültigen Zugriff verursacht wird, und der
Fehlseitenbedingung (#14), die durch den Zugriff auf eine nicht
festgeschriebene Seite bzw. eine Seite mit falschen Attributen für
die gewünschte Operation verursacht wird.
KORREKTUR: Den Händler, bei dem das Programm erworben wurde,
benachrichtigen. Sind Sie der Anwendungsentwickler, ist das
Programm anhand der Registerinformationen zu korrigieren.

-- #2nd mail
I did not yet get apopup.log from that computer, but I get simmilar 
problems here so I attached my popuplog.os2

The entries you see are the following. First I just was on de.os2.org 
and doing nothing with mozilla it was just in the back. After some 
time I got the error message. I wondered when I read that the Mail 
part crashes, as I think I didn't had that open. But may be it's the 
automatic mail check! Btw I checked sound on mailincoming, but Mozilla 
doesn't make any nois when a mail comes in.

The second entry is reproducable at this machine: I'm in mailpart, 
open news.scitechsoft.com beta.scitech.display.doctor.os2 (I have ask 
before downloading 500 DISABLED) and it crashes.

Let me know if I can send you additional debug information.
-- popuplog.os2


07-11-2001  12:16:57  SYS3175  PID 0046  TID 0001  Slot 00a7
C:\APPS\NETWORK\WARPZILLA\BIN\MOZILLA.EXE
c0000005
0f704df5
P1=00000001  P2=00000008  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=00000001  ECX=000388cf  EDX=00000001
ESI=00000000  EDI=00000001  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:0f704df5  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00131840  SSACC=f0f3  SSLIM=ffffffff
EBP=014149f8  FLG=00012246

MAILNEWS.DLL 0001:00034df5

------------------------------------------------------------

07-11-2001  12:18:20  SYS3171  PID 005b  TID 0001  Slot 00a7
C:\APPS\NETWORK\WARPZILLA\BIN\MOZILLA.EXE
c0000005
111b83a0
P1=00000002  P2=0002fffc  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00310004  EBX=0000002c  ECX=00310000  EDX=ffffffff
ESI=ffffffff  EDI=00000000  
DS=0053  DSACC=f0f3  DSLIM=ffffffff  
ES=0053  ESACC=f0f3  ESLIM=ffffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:111b83a0  CSACC=f0df  CSLIM=ffffffff
SS:ESP=0053:00030000  SSACC=f0f3  SSLIM=ffffffff
EBP=0003003c  FLG=00012202

MOZRMI36.DLL 0002:000183a0

------------------------------------------------------------

Comment 5

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

17 years ago
I got this one.

It's a bug in the C++ optimizer.

I have opened a bug with the compiler team.
Status: NEW → ASSIGNED
Summary: Mail crashes on PII 233 → OS/2 only - Mail crashes on PII 233

Comment 7

17 years ago
Removing stackwanted per last comment from Michael Kaply.
Keywords: stackwanted

Comment 8

17 years ago
We received a fix for this from the compiler team finally.

I am going to mark this fixed. All future builds will use this new optimizer.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
No response from reporter so I am verifying.

We definitely saw this problem (inclduing our test team) and it was 
definitely fixed by the new compiler optimizer.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.