[Statusbar] time is not displayed after language is changed.

RESOLVED DUPLICATE of bug 894734

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 894734
5 years ago
5 years ago

People

(Reporter: Leo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Steps to repro:

Step 1: Go to Settings and change language.
Step 2: Observe the time in statusbar disappears.

Note that after screen off and on, the time in statusbar appears normal.


Personal email id:  hanj.kim25@gmail.com

Comment 1

5 years ago
The problem was, the init() is called when language is changed and this.icons.time.hidden is true by default there.

How about adding the following at the end of statusbar.js?


  localized: function sb_localized() {
    this.init();
    
    if (!LockScreen.locked)
      this.icons.time.hidden = false;
  }
};

if (navigator.mozL10n.readyState == 'complete' ||
    navigator.mozL10n.readyState == 'interactive') {
  StatusBar.init();
} else {
  window.addEventListener('localized', StatusBar.localized.bind(StatusBar));
}

Let me create a pull request for this if you are okay with this.
Flags: needinfo?(alive)
(Reporter)

Comment 3

5 years ago
Y(In reply to Alive Kuo [:alive] from comment #2)
> https://bugzilla.mozilla.org/show_bug.cgi?id=894734
> 
> ^Same issue?

Yes, they are the same.
Thank you.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 894734
You need to log in before you can comment on or make changes to this bug.