Defect - Intermittent browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout

RESOLVED FIXED in Firefox 26
(NeedInfo fromanyone)

Status

defect
P3
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jimm, Assigned: jwilde, NeedInfo)

Tracking

(Blocks 1 bug, {intermittent-failure})

Trunk
Firefox 26
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(firefox24 unaffected, firefox25 unaffected, firefox26 fixed)

Details

(Whiteboard: feature=defect c=testing u=developer p=2)

Attachments

(1 attachment)

Reporter

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=25469851&tree=Mozilla-Inbound
WINNT 6.2 mozilla-inbound opt test mochitest-metro-chrome on 2013-07-18 20:33:32
revision: 3772e15f1b45
slave: t-w864-ix-053

20:36:26    ERROR - Return code: 1
20:36:27    ERROR - Return code: 1
20:38:34  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout at waitForEvent@chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/head.js:281
20:38:34  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout at waitForEvent@chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/head.js:281
20:38:36  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout at waitForEvent@chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/head.js:281
20:38:37  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/metro/browser/metro/base/tests/mochitest/browser_context_menu_tests.js | Left position is 293.5, expected between 265 and 280
..
..
Reporter

Updated

6 years ago
Blocks: 880298
Priority: -- → P3
Summary: Intermittent browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout → Defect - Intermittent browser_context_menu_tests.js | runTests: Task failed - Error: popupshown event timeout
Whiteboard: feature=defect c=testing u=developer p=0
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
This seems to have gotten much more frequent recently. Unfortunately, it regressed during a series of busted pushes. I'm guessing maybe bug 899730?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Actually, Bug 897409 seems more likely?
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #4)
> This seems to have gotten much more frequent recently. Unfortunately, it
> regressed during a series of busted pushes. I'm guessing maybe bug 899730?

Bug 866232 is the only thing I see in the regression range that touched Metro code; it seems most likely to me.  If I'm right, we should see this more frequently on m-c pushes even before the other bugs in the range land there.

For reference, the regression range is:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4887f7d34df2&tochange=0d8409268f42
Except bug 866232 was green on birch and on the merge to m-c.
https://tbpl.mozilla.org/?rev=60bf7ceba890
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Blocks: 893117
Reporter

Updated

6 years ago
No longer blocks: 865451
Comment hidden (Legacy TBPL/Treeherder Robot)
Assignee

Comment 30

6 years ago
It's looking like changes in bug 856264 may clean up the intermittent oranges. Running two try jobs:

 - control (no fix): https://tbpl.mozilla.org/?tree=Try&rev=b398f08afacb
 - experiment (fix from 856264): https://tbpl.mozilla.org/?tree=Try&rev=d52636a240fe

Will re-rerun the mc tests a number of times to see if there's any significant difference in number of intermittent oranges between the two.
Assignee

Comment 31

6 years ago
Updated try links:

 - control (no fix): https://tbpl.mozilla.org/?tree=Try&rev=b398f08afacb
 - experiment (fix from 856264): https://tbpl.mozilla.org/?tree=Try&rev=73e89450a0e2
Reporter

Comment 32

6 years ago
(In reply to Jonathan Wilde [:jwilde] from comment #31)
> Updated try links:
> 
>  - control (no fix): https://tbpl.mozilla.org/?tree=Try&rev=b398f08afacb
>  - experiment (fix from 856264):
> https://tbpl.mozilla.org/?tree=Try&rev=73e89450a0e2

naturally everything is green. :/ I'd suggest landing with the tests enabled, if things aren't cleaned up yet we can disable them again.
Assignee

Updated

6 years ago
Assignee: nobody → jwilde
Status: NEW → ASSIGNED
Hey Jonathan, can you provide a point estimate for this defect.
Flags: needinfo?(jwilde)
Assignee

Comment 35

6 years ago
For the set of changes we're proposing, p=2 since the work came for free with 856264. If this ends up not fixing it, we'll likely need to end up increasing the points by a significant margin.
Flags: needinfo?(jwilde)
Thanks for the update Jonathan.
Blocks: metrov1it12
No longer blocks: metrov2defect&change
QA Contact: jbecerra
Whiteboard: feature=defect c=testing u=developer p=0 → feature=defect c=testing u=developer p=2
Reporter

Comment 37

6 years ago
Comment on attachment 787717 [details] [diff] [review]
reenabling the testsuite. requires fix for 856264

Review of attachment 787717 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/tests/mochitest/browser_context_menu_tests.js
@@ +352,5 @@
>    }
>  });
>  
> +/*
> +XXX disabled temporarily due to bug 880739

Actually this was debug code that was added to diagnose bug 880739. I can still be turned off, but this comment is misleading.

@@ +392,5 @@
>  gTests.push({
>    desc: "image context menu",
>    setUp: function() {
> +    //XXX disabled temporarily due to bug 880739
> +    //observeLogger.init();

ditto.

@@ +397,4 @@
>    },
>    tearDown: function() {
> +    //XXX disabled temporarily due to bug 880739
> +    //observeLogger.shutdown();

ditto.
Attachment #787717 - Flags: review?(jmathies) → review+
Assignee

Comment 38

6 years ago
https://hg.mozilla.org/integration/fx-team/rev/a1bbe2f01047
Whiteboard: feature=defect c=testing u=developer p=2 → feature=defect c=testing u=developer p=2[fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/a1bbe2f01047
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: feature=defect c=testing u=developer p=2[fixed-in-fx-team] → feature=defect c=testing u=developer p=2
Target Milestone: --- → Firefox 26
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Blocks: metrov1it13
No longer blocks: metrov1it12
Comment hidden (Legacy TBPL/Treeherder Robot)
The last two were actually bustage from bug 883953.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Is there anything that QA can do here? Could anyone please give any guidelines that can help the QA in verifying this issue? Thanks!
Flags: needinfo?
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.