[B2G] [Leo] [Homescreen] Moving icon to another page causes icons at destination to half render

RESOLVED FIXED in Firefox 25

Status

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ckreinbring, Assigned: sotaro)

Tracking

({regression, smoketest})

unspecified
1.1 QE5
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:-, firefox25 fixed, b2g18 verified, b2g-v1.1hd affected)

Details

Attachments

(2 attachments)

Description:
Moving an app to another page with icons causes the other icons to show only the bottom half after the moved app is released.

Repro Steps:
1) Update Leo to Build ID: 20130719070225
2) Navigate to a homescreen page with app icons.
3) Longtap an icon until it enlarges, then move it to another page with app icons.
4) Release the app icon on the page and observe the other app icons.

Actual:
The top half of the other app icons on the page and in the ribbon disappear after the moved app is released.

Expected:
The other app icons continue to pulse after the moved app is released.  No other effect is shown.

Environmental Variables
Build ID: 20130719070225
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6b6e80e9aaf0
Gaia: ce5a75acd4ad6cd0d53dad77c058a0f1002f98b1
Platform Version: 18.1
RIL Version: 01.01.00.019.164

Notes:
Repro frequency: 100%
Q Analysts Team Priority: Pri 2
See attached screenshot and logcat logs
blocking-b2g: --- → leo?
Keywords: regression
Sometimes you don't have to move an icon to another screen.  Just longtapping an icon to put the device in move/delete mode is enough to make the icons half-render.
Leo device, works:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/7f6f4bc1a621
Gaia   f1d2e3fd806dc55f167c72ac8ef7a3b6baed915e
BuildID 20130718070206
Version 18.1

Broken:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b11cbde4f5f1
Gaia   4abea646d93973d1d0bfae7f82783655cd5ea393
BuildID 20130718230225
Version 18.1
Regression candidate here would likely have to be graphics related. My initial guesses are either:

- bug 873937
- bug 884188
- bug 891884

Of those three, my best guess is probably bug 884188.

Peter - Could bug 884188 cause this regression?
Blocks: 884188
Flags: needinfo?(pchang)
Assignee

Comment 5

6 years ago
bug 873937 makes problem :-( I made the regression. I take the bug.
Assignee: nobody → sotaro.ikeda.g
Assignee

Comment 6

6 years ago
Is it necessary to back out soon?
Blocks: 873937
No longer blocks: 884188
(In reply to Sotaro Ikeda [:sotaro] from comment #6)
> Is it necessary to back out soon?

Yes. Mainly because this broke a smoketest on device, it's probably better to back out bug 873937.
Flags: needinfo?(pchang)
Component: Gaia::Homescreen → General
Assignee

Comment 8

6 years ago
I have never back out a patch by myself. How can I back out the patch?
(In reply to Sotaro Ikeda [:sotaro] from comment #8)
> I have never back out a patch by myself. How can I back out the patch?

I'll ping in #b2g to see if I can find someone to back the patch out. If that doesn't work, I'll try #developers. If that fails, I'll ping RyanVM, although he doesn't appear to be on IRC right now.
Assignee

Comment 10

6 years ago
Thanks.
If someone else gets to this first, feel free to back out bug 873937. If not, I'm putting needinfo on RyanVM to backout bug 873937.
Flags: needinfo?(ryanvm)
Flagging checkin-needed for the backout.
Keywords: checkin-needed
Backed out. This will land on m-c and the v1.1hd branch as part of the regularly-scheduled branch merges at some point.
https://hg.mozilla.org/projects/birch/rev/cac24283746e
https://hg.mozilla.org/releases/mozilla-b2g18/rev/58a545e44ac0
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
Target Milestone: --- → 1.1 QE5

Comment 14

6 years ago
Issue no longer seems to be occurring on a Leo device running the latest build from the commercial 1.1 branch:

Environmental  Variables:
Build ID: 20130722070207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/68fb0a2e0114
Gaia: 41d10fb10be6916e6554eb440d9a97130ef23ce0
Platform Version: 18.1
RIL Version: 01.01.00.019.164

The icons display as they should when moving them from page to page.
Assignee

Comment 15

6 years ago
Fixed by the backout of bug 873937.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: leo? → -
You need to log in before you can comment on or make changes to this bug.