[Helix] Extra White or Black background showing up behind the app while minimizing it.

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: swaroopa, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 778717 [details]
Video

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/574fd9fa525e
Gaia   2a0b3acd3d10ca285771740c3a907b88a4c053aa
BuildID 20130719070223
Version 18.0

STR:

1.Goto the home screen and from the bottom navigation open Contacts app and click on Home button.
2. Do the same for the messages and Phone apps. Click on the app to open it and then click the home button

Expected behavior:
The change from app view to the homescreen should be neat without any extra distortions.

Actual Behavior:
Observe that as the app screen disappears, either white or black background is shown behind the app.

Attached a video..let me know if this not clear.
Should be a async animation issue, need to loop gfx ppl. Vivien can help.
Component: Gaia::Homescreen → General
Flags: needinfo?(21)
Component: General → Graphics
Product: Boot2Gecko → Core
Flags: needinfo?(21) → needinfo?(dzbarsky)
I'm not sure what device this is, but I can't reproduce it on my Unagi.  This might be related to all the async animation warnings we're seeing in the UI.  It may be worth bisecting gaia on a debug b2g build to find the change that regressed this.  Nick, you have any ideas?
Flags: needinfo?(dzbarsky) → needinfo?(ncameron)
(In reply to David Zbarsky (:dzbarsky) from comment #2)
> I'm not sure what device this is, but I can't reproduce it on my Unagi. 
> This might be related to all the async animation warnings we're seeing in
> the UI.  It may be worth bisecting gaia on a debug b2g build to find the
> change that regressed this.  Nick, you have any ideas?

David, I guess the difference matters on this particular is having |layout.css.devPixelsPerPix| set to 1.5. If you have a SGS2 around you should be able to reproduce it.

Comment 4

4 years ago
Sounds like bug 849399, could it have reappeared?

Can you repro this on desktop by pref'ing on OMTC and OMTA and zooming in on a page with animation? If so, then it would be good to have a simplified test case so we know if it is a transition on opacity or size, or whether it is due to page loading.

(Another thought is that the flash could be due to loading the page, but the page loading should start when the animation starts, so this seems unlikely).
Flags: needinfo?(ncameron)
(In reply to Nick Cameron [:nrc] from comment #4)
> Sounds like bug 849399, could it have reappeared?
> 
> Can you repro this on desktop by pref'ing on OMTC and OMTA and zooming in on
> a page with animation? If so, then it would be good to have a simplified
> test case so we know if it is a transition on opacity or size, or whether it
> is due to page loading.
> 
> (Another thought is that the flash could be due to loading the page, but the
> page loading should start when the animation starts, so this seems unlikely).

Ouch, I didn't realized this bug has been sit here for 3 weeks....

Anyhow, I turned on 
layers.offmainthreadcomposition.enabled
layers.offmainthreadcomposition.async-animations
and set 
layout.css.devPixelsPerPix
to 1.5 and test on Nightly, and I didn't saw any glitch. This did not rule out anything if I didn't test this correctly or if this only happens on b2g18.
Flags: needinfo?(ncameron)

Comment 6

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #5)
> (In reply to Nick Cameron [:nrc] from comment #4)
> > Sounds like bug 849399, could it have reappeared?
> > 
> > Can you repro this on desktop by pref'ing on OMTC and OMTA and zooming in on
> > a page with animation? If so, then it would be good to have a simplified
> > test case so we know if it is a transition on opacity or size, or whether it
> > is due to page loading.
> > 
> > (Another thought is that the flash could be due to loading the page, but the
> > page loading should start when the animation starts, so this seems unlikely).
> 
> Ouch, I didn't realized this bug has been sit here for 3 weeks....
> 
> Anyhow, I turned on 
> layers.offmainthreadcomposition.enabled
> layers.offmainthreadcomposition.async-animations
> and set 
> layout.css.devPixelsPerPix
> to 1.5 and test on Nightly, and I didn't saw any glitch. This did not rule
> out anything if I didn't test this correctly or if this only happens on
> b2g18.

Not sure I can suggest anything else.

Can you repro on the phone but using m-c instead of b2g18? That would implicate 849399, which doesn't look like it landed on b2g18, only inbound. In which case we should try and rebase that and see if it fixes things.
Flags: needinfo?(ncameron)
(In reply to Nick Cameron [:nrc] from comment #6)
> (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #5)
> > Ouch, I didn't realized this bug has been sit here for 3 weeks....
> > 
> > Anyhow, I turned on 
> > layers.offmainthreadcomposition.enabled
> > layers.offmainthreadcomposition.async-animations
> > and set 
> > layout.css.devPixelsPerPix
> > to 1.5 and test on Nightly, and I didn't saw any glitch. This did not rule
> > out anything if I didn't test this correctly or if this only happens on
> > b2g18.
> 
> Not sure I can suggest anything else.
> 
> Can you repro on the phone but using m-c instead of b2g18? That would
> implicate 849399, which doesn't look like it landed on b2g18, only inbound.
> In which case we should try and rebase that and see if it fixes things.

I cannot reproduce this bug on m-c on the phone.

Comment 8

4 years ago
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #7)
> (In reply to Nick Cameron [:nrc] from comment #6)
> > (In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #5)
> > > Ouch, I didn't realized this bug has been sit here for 3 weeks....
> > > 
> > > Anyhow, I turned on 
> > > layers.offmainthreadcomposition.enabled
> > > layers.offmainthreadcomposition.async-animations
> > > and set 
> > > layout.css.devPixelsPerPix
> > > to 1.5 and test on Nightly, and I didn't saw any glitch. This did not rule
> > > out anything if I didn't test this correctly or if this only happens on
> > > b2g18.
> > 
> > Not sure I can suggest anything else.
> > 
> > Can you repro on the phone but using m-c instead of b2g18? That would
> > implicate 849399, which doesn't look like it landed on b2g18, only inbound.
> > In which case we should try and rebase that and see if it fixes things.
> 
> I cannot reproduce this bug on m-c on the phone.

Great, thanks for experimenting! So, that suggests we need to rebase bug 849399 to b2g18 (or persuade someone that we should use m-c for Helix :-) ). Do you want to give it a go, or do you want to leave it to me? (It shouldn't take too long, but I'm unlikely to get to it until next week some time).
This seems to have been fixed somehow, I cannot reproduce this on 20130814042202. Closing as WFM, if anyone reproduces this please provide build info and STR details.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Setting flag for correctness sake.
blocking-b2g: hd? → hd+
You need to log in before you can comment on or make changes to this bug.