Closed Bug 896149 Opened 7 years ago Closed 7 years ago

Dynamic absolute elements are not positioned correctly

Categories

(Core :: Layout, defect)

25 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 894931
Tracking Status
firefox25 - ---

People

(Reporter: developer, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130718 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130718030201

Steps to reproduce:

Open up http://community.wikia.com/wiki/Help:Poll.
You'll see a grey bar below the "Help:Poll" title.  It is covering text and it has black numbers in it that are overlapping other black numbers.

That grey bar is actually 4 grey bars that should be positioned farther down the page.  If you look at the DOM, the grey bars are children of elements farther down.  They have position: absolute and their immediate parent has position: relative so it should be positioned inside of the immediate parent.  It appears to affect dynamically added elements only because there is another element that is absolute inside of a relative and it appears correctly (CSS selector: ul.carousel). 

This is a recent regression.

I ran mozregression on this and the output is:

Last good nightly: 2013-07-16
First bad nightly: 2013-07-17

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5976b9c673f8&tochange=0888e29c83a3
Trev, this looks (based on symptomps and regression range) a lot like bug 894931.

Would you mind testing in tomorrow's (July 20th) nightly to see whether the problem is still present?
Flags: needinfo?(developer)
Sure, I'll test it tomorrow.
Flags: needinfo?(developer)
It's a dupe, yes. 
Working range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f26e4c26ce4a&tochange=af4e3ce8c487
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 894931
You need to log in before you can comment on or make changes to this bug.